aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMatthias Neugebauer <mtneug@mailbox.org>2019-03-21 17:55:06 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-23 16:28:31 +0000
commit34d0d870b08bf6accead030e307352a5353a816d (patch)
tree9d951255502e8e9fd054b3d9570d7489179f6e84 /community
parentf7e813c88bb392d99d08b0c945c7c4f61e1aab70 (diff)
downloadaports-34d0d870b08bf6accead030e307352a5353a816d.tar.bz2
aports-34d0d870b08bf6accead030e307352a5353a816d.tar.xz
testing/go-bindata: move to community
Diffstat (limited to 'community')
-rw-r--r--community/go-bindata/APKBUILD39
-rw-r--r--community/go-bindata/go-remove-runtime.patch17
2 files changed, 56 insertions, 0 deletions
diff --git a/community/go-bindata/APKBUILD b/community/go-bindata/APKBUILD
new file mode 100644
index 0000000000..ff99d0528a
--- /dev/null
+++ b/community/go-bindata/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=go-bindata
+pkgver=20151023
+_hash="a0ff2567cfb70903282db057e799fd826784d41d"
+pkgrel=0
+pkgdesc="A small utility which generates Go code from any file"
+url="https://github.com/jteeuwen/go-bindata"
+arch="all"
+license="CC0-1.0"
+makedepends="go"
+options="!check" # No test suite
+source="go-bindata-$pkgver.tar.gz::https://github.com/jteeuwen/go-bindata/archive/$_hash.tar.gz
+ go-remove-runtime.patch"
+builddir="$srcdir/src/github.com/jteeuwen/$pkgname"
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-$_hash "$builddir"/
+ default_prepare
+}
+
+build() {
+ cd "$builddir"/$pkgname
+ export GOPATH="$srcdir"
+ go build -v -o bin/$pkgname
+}
+
+package() {
+ install -Dm 755 "$builddir/$pkgname"/bin/go-bindata \
+ "$pkgdir"/usr/bin/go-bindata
+}
+
+md5sums="d630353abae8c73adf2ed2af3d0e74a0 go-bindata-20151023.tar.gz
+89f3e2b57d42c5b6ff943c7a2c99e6f4 go-remove-runtime.patch"
+sha256sums="65cf65ac422fb8072abfaabec86c20a74e448a93b489e896a36642e7049f5d32 go-bindata-20151023.tar.gz
+db1189c655e4602651cd283aeaa10efa118c8d5e343c0e872e896a9b54146174 go-remove-runtime.patch"
+sha512sums="ed1d2fd1c5a833b6efdc731eb43f72fc072a701c447a926ad6c1f9be3c0f1ed92c689639d02a288230a49d53795f41092deab132389871a5b9f79abdc525fc43 go-bindata-20151023.tar.gz
+0d8b16b3384048e1c1d168b228c293f86a06a50304e49657545770a445496acbca79670441bb14464a306a1efb94bdb371aabb1e58969b45a40fcfbb1870d9dc go-remove-runtime.patch"
diff --git a/community/go-bindata/go-remove-runtime.patch b/community/go-bindata/go-remove-runtime.patch
new file mode 100644
index 0000000000..4cb0349f72
--- /dev/null
+++ b/community/go-bindata/go-remove-runtime.patch
@@ -0,0 +1,17 @@
+--- ./go-bindata/version.go.orig
++++ ./go-bindata/version.go
+@@ -6,7 +6,6 @@
+
+ import (
+ "fmt"
+- "runtime"
+ )
+
+ const (
+@@ -27,5 +26,5 @@
+ }
+
+ return fmt.Sprintf("%s %d.%d.%s (Go runtime %s).\nCopyright (c) 2010-2013, Jim Teeuwen.",
+- AppName, AppVersionMajor, AppVersionMinor, AppVersionRev, runtime.Version())
++ AppName, AppVersionMajor, AppVersionMinor, AppVersionRev, "1.7.0")
+ }