aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 03:53:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 03:53:42 -0300
commit350b245980fc7e77dec7cf133d7f94fe4d43df89 (patch)
tree31753ed676bffdcf6acc669ad040955687a8faf2 /community
parent6b579676d90b0787da56e1c39b58d04f246c9b78 (diff)
downloadaports-350b245980fc7e77dec7cf133d7f94fe4d43df89.tar.bz2
aports-350b245980fc7e77dec7cf133d7f94fe4d43df89.tar.xz
community/zathura: add completion subpackages for all shells
Diffstat (limited to 'community')
-rw-r--r--community/zathura/APKBUILD36
1 files changed, 34 insertions, 2 deletions
diff --git a/community/zathura/APKBUILD b/community/zathura/APKBUILD
index 5337d1b93c..0320669c61 100644
--- a/community/zathura/APKBUILD
+++ b/community/zathura/APKBUILD
@@ -1,10 +1,11 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Andrew Hills <ahills@ednos.net>
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=zathura
pkgver=0.4.5
-pkgrel=2
+pkgrel=3
pkgdesc="zathura - highly customizable and functional document viewer"
url="https://git.pwmt.org/pwmt/zathura"
arch="all"
@@ -12,7 +13,14 @@ license="Zlib"
makedepends="girara-dev file-dev sqlite-dev intltool check-dev libseccomp-dev
py3-docutils ncurses meson ninja py3-sphinx desktop-file-utils appstream-glib"
checkdepends="mesa-dri-swrast dbus xvfb"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
+subpackages="
+ $pkgname-doc
+ $pkgname-dev
+ $pkgname-lang
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch
+ "
source="https://git.pwmt.org/pwmt/zathura/-/archive/$pkgver/zathura-$pkgver.tar.gz
test.sh
"
@@ -36,5 +44,29 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ amove usr/share/bash-completion/completions
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ amove usr/share/zsh/site-functions
+}
+
+fishcomp() {
+ depends=""
+ pkgdesc="Fish completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ amove usr/share/fish/completions
+}
+
sha512sums="9ce6c7745d83d7e21fcbbc6a7c799a4223cf77afbe1c933b710c1c7920c98ae1edcf683ae42433f448a091eb317f2b71b3bde9d1b27c8089d1adbc9aa0ab4e78 zathura-0.4.5.tar.gz
2190d324753810c8dc5b109274dcf4f644e51edcda876c225ac76369dd569dda0b8db445b01dac1ac2b06178534d18e1074ca37d1a69622bdc58fd77350b4ddd test.sh"