aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-06-21 22:21:08 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-06-27 14:54:48 +0200
commit3ca9f55bfe958c06a5edbda580fe9a4d86e3b5b0 (patch)
tree74b98c9042f6ce79e47dc163e654b5cd9d916251 /community
parent6ccdab86891d75ce7c66576b43b6e064eb8999e1 (diff)
downloadaports-3ca9f55bfe958c06a5edbda580fe9a4d86e3b5b0.tar.bz2
aports-3ca9f55bfe958c06a5edbda580fe9a4d86e3b5b0.tar.xz
community/asciinema: upgrade to 1.4.0 and enable on ppc64le
The upgrade from version 1.2.0 to 1.3.0 brings back the original Python implementation of asciinema[1] and it supports only Python 3. This patch changes the build to reflect the changes and also enable build on ppc64le. [1] http://blog.asciinema.org/post/and-now-for-something-completely-different/
Diffstat (limited to 'community')
-rw-r--r--community/asciinema/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/community/asciinema/APKBUILD b/community/asciinema/APKBUILD
index 4e5b4be9f2..5e2847179a 100644
--- a/community/asciinema/APKBUILD
+++ b/community/asciinema/APKBUILD
@@ -1,32 +1,25 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=asciinema
-pkgver=1.2.0
+pkgver=1.4.0
pkgrel=0
pkgdesc="A Command line recorder for asciinema.org service"
url="https://github.com/asciinema/asciinema/"
-arch="all !aarch64 !ppc64le !s390x"
+arch="all !aarch64 !s390x"
license="GPLv3"
-depends="curl"
-depends_dev=""
-makedepends="go python2"
-subpackages="$pkgname-doc"
-options="!strip"
+depends="ncurses"
+makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
-
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- export GOPATH="$builddir"
- mkdir -p src/github.com/asciinema
- ln -s "$builddir" src/github.com/asciinema/asciinema
- make build
+ python3 setup.py build
}
package() {
cd "$builddir"
- PREFIX="$pkgdir"/usr make install
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="b172fa2c122ce6d4191d898292f70b462f18c9436a7a95b56a3d4405f66a4003d52877b5d632a829f94704f7d8a07c1202f1d3059e1eec6b583b63daf90a9006 asciinema-1.2.0.tar.gz"
+sha512sums="23c67a462acdbbbed495e6cc3e0e22ed028effcc945af30b5925854e216c6f74bb1b416d9b0001726732ae8be510796e996bbca69b225c20422143e5ed1aca5c asciinema-1.4.0.tar.gz"