aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 15:11:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-12 14:15:05 +0000
commit42c1031d897851f9cec274df5e0e6f5ca8416928 (patch)
tree53aef8f613c4bbc920ffbc37a3eac9742228d25e /community
parent92c92b348a129526b80210759b8650607a18e484 (diff)
downloadaports-42c1031d897851f9cec274df5e0e6f5ca8416928.tar.bz2
aports-42c1031d897851f9cec274df5e0e6f5ca8416928.tar.xz
community/rstcheck: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/rstcheck/01-python3-test-suite.patch22
-rw-r--r--community/rstcheck/APKBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/community/rstcheck/01-python3-test-suite.patch b/community/rstcheck/01-python3-test-suite.patch
new file mode 100644
index 0000000000..d7cd1e53bd
--- /dev/null
+++ b/community/rstcheck/01-python3-test-suite.patch
@@ -0,0 +1,22 @@
+--- a/rstcheck.py
++++ b/rstcheck.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # Copyright (C) 2013-2017 Steven Myint
+ #
+--- a/test.bash
++++ b/test.bash
+@@ -73,9 +73,9 @@
+ # Ignore message on configuration file
+ ./rstcheck.py examples/with_configuration/bad-2.rst
+
+-if python -c 'import sys; sys.exit(0 if sys.version_info >= (3,) else 1)'
++if python3 -c 'import sys; sys.exit(0 if sys.version_info >= (3,) else 1)'
+ then
+- python -m doctest -v README.rst rstcheck.py
++ python3 -m doctest -v README.rst rstcheck.py
+ ./rstcheck.py README.rst
+ fi
+
diff --git a/community/rstcheck/APKBUILD b/community/rstcheck/APKBUILD
new file mode 100644
index 0000000000..e247aeb744
--- /dev/null
+++ b/community/rstcheck/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=rstcheck
+pkgver=3.3.1
+pkgrel=2
+pkgdesc="Checks syntax of reStructuredText and code blocks nested within it"
+url="https://github.com/myint/rstcheck"
+arch="noarch"
+license="MIT"
+depends="python3 py3-docutils py3-setuptools"
+checkdepends="bash"
+# use github because the test suite isn't part of the pypi package:
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/myint/$pkgname/archive/v$pkgver.tar.gz
+ 01-python3-test-suite.patch
+ "
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 ./test_rstcheck.py
+ bash ./test.bash
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="07431d6c4789e4c005c4bf4be66f627c390f57e56f25b4f3db8b392bc7b904ca93c3e26145ab344e9b78109d2054e5f36167ab40b1ab023f08c85d6ec12cafbc rstcheck-3.3.1.tar.gz
+e2a86661595debc58e5cf919277afbd6b50abcd97ea6d5383294b9b346a4344d837927cd678738d0f01f01d450c5a99f84732f09aa696e19e588a732d9a4c773 01-python3-test-suite.patch"