aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-27 14:48:25 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-27 14:48:25 +0000
commit4f8853cee99ff582f9ab78a385ed1ee85b0299fc (patch)
tree562add8e60b82628390d463ec84ef329b0ecbd41 /community
parenta6a1fd9a7521771edf81691e8b8f7891e7271b23 (diff)
downloadaports-4f8853cee99ff582f9ab78a385ed1ee85b0299fc.tar.bz2
aports-4f8853cee99ff582f9ab78a385ed1ee85b0299fc.tar.xz
community/py-cparser: added install_if to pull the right python version
Diffstat (limited to 'community')
-rw-r--r--community/py-cparser/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/py-cparser/APKBUILD b/community/py-cparser/APKBUILD
index c2ce5efb9c..90f3624f80 100644
--- a/community/py-cparser/APKBUILD
+++ b/community/py-cparser/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=py-cparser
pkgver=2.14
-pkgrel=1
+pkgrel=2
pkgdesc="a C parser written in Python"
url="https://github.com/eliben/pycparser"
arch="noarch"
license="BSD"
depends=""
-makedepends="python-dev python3-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools"
install=""
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/p/pycparser/pycparser-$pkgver.tar.gz"
@@ -27,7 +27,7 @@ package() {
_py() {
local python=$1
pkgdesc="$pkgdesc - $python"
-
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}