aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-04 12:42:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-04 13:14:30 -0300
commit52ef2b86526df5d1a4c268d4c76252f28fff72ae (patch)
treea003bc3d10f0a398ee1cb8c49f55de90387d07ff /community
parent83b638985fdb6933415590d159ea98bba40d0379 (diff)
downloadaports-52ef2b86526df5d1a4c268d4c76252f28fff72ae.tar.bz2
aports-52ef2b86526df5d1a4c268d4c76252f28fff72ae.tar.xz
community/uptimed: upgrade to 0.4.2
Diffstat (limited to 'community')
-rw-r--r--community/uptimed/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/uptimed/APKBUILD b/community/uptimed/APKBUILD
index 07a05355ad..aa93856f7e 100644
--- a/community/uptimed/APKBUILD
+++ b/community/uptimed/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Maintainer:
pkgname=uptimed
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=0
pkgdesc='System uptime record daemon'
arch="all"
@@ -12,22 +12,24 @@ subpackages="$pkgname-doc $pkgname-openrc"
makedepends="autoconf automake libtool"
source="$pkgname-$pkgver.tar.gz::https://github.com/rpodgorny/uptimed/archive/v$pkgver.tar.gz
uptimed.init"
-builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
autoreconf -vif
+}
+
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man \
+ --disable-static
make
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
mv "$pkgdir"/etc/uptimed.conf-dist \
"$pkgdir"/etc/uptimed.conf
@@ -35,5 +37,5 @@ package() {
"$pkgdir"/etc/init.d/uptimed
}
-sha512sums="5dfe79aebab8c8daca3a3ec88d54e312446fc7cf8b54ef1414cbfcb3fb25053ef31235de4b42cb14fc7352965b77ca2875c753b97b4d61178792a5484715e23a uptimed-0.4.1.tar.gz
+sha512sums="a18cc8580a4dc7db7f4d97d70e25d76e7b98b9d328a0fa4ece4176d40fc26589149d63ffc9d2638cc35003cf485b43ae6e115aa1821c662d77f234eb3c4c0a4f uptimed-0.4.2.tar.gz
0884e9f5ace5a69b8eea4401c7f3b84f0a434f0ceb2b920919e83f318eb9e54182932de174cf1666ddddbab84c146781f3dd78571e80cc274963a72bf4f53a6b uptimed.init"