aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2019-04-09 10:43:18 +0200
committerAndré Klitzing <aklitzing@gmail.com>2019-04-09 11:05:55 +0200
commit5349367e149e4e804267edb3db6d179fb279ce71 (patch)
tree6fb61787dd146c7da143d8aa2bb43dc5cf06cc09 /community
parent05393ff452cfefa514767a10c4f143fb24aad108 (diff)
downloadaports-5349367e149e4e804267edb3db6d179fb279ce71.tar.bz2
aports-5349367e149e4e804267edb3db6d179fb279ce71.tar.xz
community/py-pyutilib: moved from testing
checkdepends of gcovr
Diffstat (limited to 'community')
-rw-r--r--community/py-pyutilib/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/py-pyutilib/APKBUILD b/community/py-pyutilib/APKBUILD
new file mode 100644
index 0000000000..464b92fa5f
--- /dev/null
+++ b/community/py-pyutilib/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-pyutilib
+_pkgname=PyUtilib
+pkgver=5.6.5
+pkgrel=0
+pkgdesc="A collection of Python utilities"
+url="https://pypi.org/project/PyUtilib/"
+arch="noarch"
+license="BSD"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="https://files.pythonhosted.org/packages/source/p/pyutilib/$_pkgname-$pkgver.tar.gz"
+options="!check" # no upstream tests
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="5e7f86c29ff81cfffea5862d09ec8d026739f09b172606acd4d08dc4a9bde28c8b63b8e51634d17c3161b46e7e8c8881050044baa22bc07b0926efe46ed7331d PyUtilib-5.6.5.tar.gz"