aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-22 10:28:15 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 06:54:40 -0300
commit5d21a1342b8ad54390ee8c5f1bbd2b78b23a68e8 (patch)
treebc683312a05b8119a7882663027becdcbd39022d /community
parent26ee862b9f96247bd8e7b339752efdbc6a77f55c (diff)
downloadaports-5d21a1342b8ad54390ee8c5f1bbd2b78b23a68e8.tar.bz2
aports-5d21a1342b8ad54390ee8c5f1bbd2b78b23a68e8.tar.xz
community/libphonenumber: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/libphonenumber/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libphonenumber/APKBUILD b/community/libphonenumber/APKBUILD
new file mode 100644
index 0000000000..ac619e19d2
--- /dev/null
+++ b/community/libphonenumber/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bhushan Shah <bshah@kde.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libphonenumber
+pkgver=8.10.21
+pkgrel=0
+pkgdesc="Library for parsing, formatting, and validating international phone numbers."
+url="https://github.com/googlei18n/libphonenumber"
+arch="all"
+license="Apache-2.0"
+depends_dev="boost-dev protobuf-dev icu-dev"
+makedepends="$depends_dev cmake gtest-dev"
+checkdepends="gtest"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/libphonenumber/archive/v$pkgver.tar.gz"
+
+build() {
+ cd "$builddir/cpp"
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir/cpp"
+ ./libphonenumber_test
+}
+package() {
+ cd "$builddir/cpp"
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="791c3dd2f4ce2abecafac1ca2b61708152c6b51f3a417084e0163322980e83297f75e48fa71f6fa2f6fcd20fdaa233bd1f99a2ce499aec56a785cbd1fedc2662 libphonenumber-8.10.21.tar.gz"