aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-04-06 17:40:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-06 17:40:11 +0000
commit6366dcf2693172506dd7d6bb9071b7c723f14f60 (patch)
treeaca99dfa1613315085571106cfaaf6ca0494e688 /community
parent5bf0033dd58b6f68cce10b6b6ada70a4b49d9e89 (diff)
downloadaports-6366dcf2693172506dd7d6bb9071b7c723f14f60.tar.bz2
aports-6366dcf2693172506dd7d6bb9071b7c723f14f60.tar.xz
community/extra-cmake-modules: upgrade to 5.56, moved from testing due to attica dep
Diffstat (limited to 'community')
-rw-r--r--community/extra-cmake-modules/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
new file mode 100644
index 0000000000..76c97a699e
--- /dev/null
+++ b/community/extra-cmake-modules/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: k0r10n <k0r10n.dev@gmail.com>
+# Contributor: Ivan Tham <pickfire@riseup.net>
+pkgname=extra-cmake-modules
+pkgver=5.56.0
+pkgrel=0
+pkgdesc="Extra CMake modules"
+url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
+arch="noarch"
+license="custom"
+depends="cmake"
+makedepends="py-sphinx cmake"
+options="!check" #check fails because of several packages missing
+subpackages="$pkgname-doc"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ mkdir -p build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install/fast
+
+ install -Dm644 ../COPYING-CMAKE-SCRIPTS \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="8064b0807c696c9fd2ebfa8761055ad6b840b1e2d6a3bf7f297099bf0eda5b5b65376294501bdac830839f4874391ecc85e5306b5e93c5fbac3b6aa2689a888e extra-cmake-modules-5.56.0.tar.xz"