aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-05 11:49:03 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-07 07:45:55 +0100
commit691bdec6c820d5de8deec54c1d50153b59dbd1d8 (patch)
tree9b3eb55b132a5e13ff38bb98880d31e25c538843 /community
parentf2e57e2155c621a8fd59447f46eba2666d8722a9 (diff)
downloadaports-691bdec6c820d5de8deec54c1d50153b59dbd1d8.tar.bz2
aports-691bdec6c820d5de8deec54c1d50153b59dbd1d8.tar.xz
community/gtksourceview4: move glade catalogs to -dev
Diffstat (limited to 'community')
-rw-r--r--community/gtksourceview4/APKBUILD18
-rw-r--r--community/gtksourceview4/skip-test.patch14
2 files changed, 27 insertions, 5 deletions
diff --git a/community/gtksourceview4/APKBUILD b/community/gtksourceview4/APKBUILD
index b6b9acf8a0..e939b817ce 100644
--- a/community/gtksourceview4/APKBUILD
+++ b/community/gtksourceview4/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gtksourceview4
pkgver=4.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="A text widget adding syntax highlighting and more to GNOME"
url="https://wiki.gnome.org/Projects/GtkSourceView"
arch="all !s390x" # Limited by ibus -> librsvg
@@ -10,10 +10,11 @@ license="GPL-2.0-or-later"
replaces="gtksourceview"
depends_dev="gtk+3.0-dev libxml2-dev"
makedepends="$depends_dev gobject-introspection-dev vala libxslt meson glade-dev"
-checkdepends="xvfb-run ibus"
+checkdepends="xvfb-run ibus dbus"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/gtksourceview/${pkgver%.*}/gtksourceview-$pkgver.tar.xz"
-
+source="https://download.gnome.org/sources/gtksourceview/${pkgver%.*}/gtksourceview-$pkgver.tar.xz
+ skip-test.patch
+ "
builddir="$srcdir/gtksourceview-$pkgver"
build() {
@@ -35,4 +36,11 @@ check() {
package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="068e723525290c5356c5ce3f5e5b5b8ecc9f7b1ff2f8234da247d1a84bed63ff5601cad6550981720859286e107705ec25cc7793b754ada164ec6569df0df9eb gtksourceview-4.4.0.tar.xz"
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/glade/catalogs "$subpkgdir"/usr/share/
+}
+sha512sums="068e723525290c5356c5ce3f5e5b5b8ecc9f7b1ff2f8234da247d1a84bed63ff5601cad6550981720859286e107705ec25cc7793b754ada164ec6569df0df9eb gtksourceview-4.4.0.tar.xz
+c765c7c77a94007e95c050c05ef0283b2cdcd5751274924ea08a02ea2507061677d7f286c3e98d6b91f3603a06364d1ea43491e77e2e086e05c841218923e771 skip-test.patch"
diff --git a/community/gtksourceview4/skip-test.patch b/community/gtksourceview4/skip-test.patch
new file mode 100644
index 0000000000..9622cab208
--- /dev/null
+++ b/community/gtksourceview4/skip-test.patch
@@ -0,0 +1,14 @@
+This test tries to access /var/lib/dbus/machine-id because of its usage of IBus.
+
+diff --git a/testsuite/meson.build b/testsuite/meson.build
+index f842a07..bd31ec8 100644
+--- a/testsuite/meson.build
++++ b/testsuite/meson.build
+@@ -34,7 +34,6 @@ testsuite_sources = [
+ ['test-styleschememanager'],
+ ['test-undo-manager'],
+ ['test-utils'],
+- ['test-view'],
+ ]
+
+ foreach test: testsuite_sources