aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorPureTryOut <bribbers@disroot.org>2019-01-20 18:20:04 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-06 11:07:59 +0000
commit69b0b34f6baa65e16fdad70fe09b16a5b27a944b (patch)
treede82a745aeb0c44d2ab1797534a4ef5249e54544 /community
parent3d25ed95086192623959039005f58fd36159de3b (diff)
downloadaports-69b0b34f6baa65e16fdad70fe09b16a5b27a944b.tar.bz2
aports-69b0b34f6baa65e16fdad70fe09b16a5b27a944b.tar.xz
community/qt5-qtwayland: new aport
Diffstat (limited to 'community')
-rw-r--r--community/qt5-qtwayland/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/qt5-qtwayland/APKBUILD b/community/qt5-qtwayland/APKBUILD
new file mode 100644
index 0000000000..7e6cfa5c7b
--- /dev/null
+++ b/community/qt5-qtwayland/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qt5-qtwayland
+_pkgname="${pkgname/qt5-/}-everywhere-src"
+pkgver=5.12.0
+pkgrel=0
+arch="all"
+url="http://qt-project.org/"
+license="LGPL-2.0 with exceptions or GPL-3.0 with exceptions"
+pkgdesc='Provides APIs for Wayland'
+depends="qt5-qtdeclarative libxcomposite wayland qt5-qtquickcontrols2"
+makedepends="$depends_dev libxkbcommon-dev qt5-qtquickcontrols2-dev qt5-qtbase-dev wayland-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+
+source="http://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver}/submodules/$_pkgname-$pkgver.tar.xz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
+}
+sha512sums="a6819a918a8249861253ca24109888c4af26e5a75b746d10a516c1abe5c685a2aed85f9a57832596480e89870d8f189ee63609df983ed826148a62f60fb823bc qtwayland-everywhere-src-5.12.0.tar.xz"