aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2016-04-20 21:06:54 +0000
committerTed Trask <ttrask01@yahoo.com>2016-04-20 21:06:54 +0000
commit6d6b0dced68f5d291ed67a3bf98b82a81a0fb24e (patch)
tree5a256f0b7b3404f1f290d6ccc672cb595029cfc9 /community
parent61d903698f762e655fba9e83a91c7a4733ae786b (diff)
downloadaports-6d6b0dced68f5d291ed67a3bf98b82a81a0fb24e.tar.bz2
aports-6d6b0dced68f5d291ed67a3bf98b82a81a0fb24e.tar.xz
community/acf-provisioning-*: move firmware packages into community
This includes moving cyberdata out of testing
Diffstat (limited to 'community')
-rw-r--r--community/acf-provisioning-algo/APKBUILD39
-rw-r--r--community/acf-provisioning-algo/init.cfg.sample20
-rw-r--r--community/acf-provisioning-cisco/APKBUILD33
-rw-r--r--community/acf-provisioning-cisco/SPA112.cfg6
-rw-r--r--community/acf-provisioning-cisco/init.cfg4
-rw-r--r--community/acf-provisioning-cyberdata/000000cd.xml6
-rw-r--r--community/acf-provisioning-cyberdata/APKBUILD35
-rw-r--r--community/acf-provisioning-linksys/APKBUILD25
-rw-r--r--community/acf-provisioning-linksys/PAP2T.cfg6
-rw-r--r--community/acf-provisioning-linksys/init.cfg4
-rw-r--r--community/acf-provisioning-polycom/000000000000-directory.xml4
-rw-r--r--community/acf-provisioning-polycom/000000000000-phone.cfg5
-rw-r--r--community/acf-provisioning-polycom/000000000000-web.cfg5
-rw-r--r--community/acf-provisioning-polycom/000000000000.cfg.patch30
-rw-r--r--community/acf-provisioning-polycom/APKBUILD106
-rw-r--r--community/acf-provisioning-snom/APKBUILD47
-rw-r--r--community/acf-provisioning-snom/snom300-firmware.htm4
-rw-r--r--community/acf-provisioning-snom/snom320-firmware.htm4
-rw-r--r--community/acf-provisioning-snom/snom360-firmware.htm4
-rw-r--r--community/acf-provisioning-snom/snom370-firmware.htm4
20 files changed, 391 insertions, 0 deletions
diff --git a/community/acf-provisioning-algo/APKBUILD b/community/acf-provisioning-algo/APKBUILD
new file mode 100644
index 0000000000..1c1f48570c
--- /dev/null
+++ b/community/acf-provisioning-algo/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Seung Soo Mun <hamletmun@gmail.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-algo
+pkgver=2.4
+pkgrel=1
+pkgdesc="Files for provisioning Algo Products"
+url="http://www.algosolutions.com/products/overview.html"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+source="http://www.algosolutions.com/fw-downloads/8180/firmware/algo-8180-2.4.fw
+http://www.algosolutions.com/fw-downloads/md5download.php?filename=8180/firmware/algo-8180-2.4.md5
+http://www.algosolutions.com/fw-downloads/8180/kernel/algo-pa-kernel-r5.fw
+http://www.algosolutions.com/fw-downloads/md5download.php?filename=8180/kernel/algo-pa-kernel-r5.md5
+init.cfg.sample"
+subpackages=""
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Algo
+ cp *.cfg.sample *.fw *.md5 "$pkgdir"/var/www/provisioning/htdocs/Algo
+}
+
+md5sums="1de8b7d5a475269cd0d4a56d030b2078 algo-8180-2.4.fw
+6784fb98bb79d1730c64b8b7c09d67d6 algo-8180-2.4.md5
+b48fcb591c7873a00b0d2323be771446 algo-pa-kernel-r5.fw
+f7f6887a7cc92b46914f562612ba3841 algo-pa-kernel-r5.md5
+7f6b26f11c1f81ac444c5c0f80e56212 init.cfg.sample"
+sha256sums="10e58d5724a60a6628add20171c0d5f5792cd911e02d72927f7ec4ec9d474a47 algo-8180-2.4.fw
+3261f7cd4b9bb143fae398e8da088a146c2ed74cf159377eedc99c68461abd8e algo-8180-2.4.md5
+b59b62c6bfa79d1547fce02080aa78998248c9f6260599dc865c35ffbe47b8d8 algo-pa-kernel-r5.fw
+cb46df70da381320cfdc47280687bf1660e50c0ebc3a2c276ea6c1c75b1f49eb algo-pa-kernel-r5.md5
+51426dceb6e5f40cda289ca9bb034aac24e0a53f2c16aea3d03a05480134910b init.cfg.sample"
+sha512sums="ec1ede724eb0485e0b92b0fdf4f969e03e067634be684bd2aa4d853ecaabf6837f12ca607f8bd9b6529932785e5ce26472b76ecf0a61d93a94d1d6ded2fe9ac0 algo-8180-2.4.fw
+44df87dc2bf929a12133a40809b5ad1e1967cb70cd474b833a9c6c0b2ec83fe5d05d52350fc2575af4fa0a793fba099ba95d5b5d08d822a8739a320714d14ece algo-8180-2.4.md5
+9282f2e4c2c178b08af66c86d27681484edc2d3729ebcf7786442f73f4d8ec4be42358b527dc38388fb3f68bc09ca666e6fc8be49cc1dbeb5c305ad9cebb14b8 algo-pa-kernel-r5.fw
+f86db2a891c2097f26f58cd484b4fa05ce67387ecafbe8daa3f8dcbf851cdeeb22553fefa53acedefd89e98e25a3d3c9d0c4ac5e42e897a204ee9473ee340165 algo-pa-kernel-r5.md5
+8ebb6ab8b0a288d3f08891654943988cbc42a08b113f4e72beb74e98de3b4b608f4dd904879dfb3d131f2225bfa6990478cc12cb00c0d872b53ebaa464d9f998 init.cfg.sample"
diff --git a/community/acf-provisioning-algo/init.cfg.sample b/community/acf-provisioning-algo/init.cfg.sample
new file mode 100644
index 0000000000..4a673ac8ae
--- /dev/null
+++ b/community/acf-provisioning-algo/init.cfg.sample
@@ -0,0 +1,20 @@
+net.dscp.rtp = 101110
+net.dscp.sip = 101110
+net.vlan.id = 1
+net.vlan.priority = 5
+net.vlan.use = 1
+prov.download.cfgpath = Algo
+prov.download.fwgpath = Algo
+prov.download.method = http
+prov.server.method = static
+prov.server.static = 10.0.0.1
+prov.version.firmware = 2.4
+prov.version.kernel = r5
+sip.alert2.use = 1
+audio.ring.tone2 = buzzer.wav
+sip.alert3.use = 1
+audio.ring.tone3 = chime.wav
+sip.alert4.use = 1
+audio.ring.tone4 = dogs.wav
+sip.alert5.use = 1
+audio.ring.tone5 = gong.wav
diff --git a/community/acf-provisioning-cisco/APKBUILD b/community/acf-provisioning-cisco/APKBUILD
new file mode 100644
index 0000000000..10f1d513ff
--- /dev/null
+++ b/community/acf-provisioning-cisco/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Ted Trask <ttrask01@yahoo.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-cisco
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Files for provisioning Cisco Small Business Voice Gateways and ATAs"
+url="http://www.cisco.com/c/en/us/support/unified-communications/small-business-voice-gateways-ata/tsd-products-support-series-home.html"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+# Source obtained from http://software.cisco.com/download/release.html?mdfid=283998771&softwareid=282463187&release=1.3.1
+# and cached on dev.alpinelinux.org
+source="http://dev.alpinelinux.org/archive/$pkgname/SPA112_SPA122_1.3.1_003_FW.zip
+init.cfg
+SPA112.cfg"
+subpackages=""
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Cisco
+ cp *.cfg *.bin "$pkgdir"/var/www/provisioning/htdocs/Cisco
+}
+
+md5sums="ccfb754a02b92418e241af6e23f23143 SPA112_SPA122_1.3.1_003_FW.zip
+4c826d078240d8e64ba084ea811a65d1 init.cfg
+2c53d509b9fe3ac51907df05d9f981ec SPA112.cfg"
+sha256sums="1c439efa769878af5a4a509e7693c606772c883f1abbab7be42874dad554e2ed SPA112_SPA122_1.3.1_003_FW.zip
+21fb6bcf79ad5919777279d3ece759ce1179959b6e870fb1f32e91bf39e777be init.cfg
+87422399d7f0b172d258dc6b32f667d551727e978a71e4d1c35e509f18ecc2f8 SPA112.cfg"
+sha512sums="86beaf3e4cb88be24d4aff823106c174a832914113c855bb1b589a7890864c42a68cb095f2e97ff7bb5aff9365b3063a60bb24d5691e4942be642ee191dd4630 SPA112_SPA122_1.3.1_003_FW.zip
+46d2544ad730b77ad36f10de07792804101c1e7bdc1c4ff0ebdca845dd2cb59ef3928fa85cd22d7e075f4504a21f804e9fd26d44db8021d29cca9271f02b3dac init.cfg
+0ece33f6ce9012a97e0e0856da93b2e6c0628caa0bc856ecce813c1caf9a3de4b6ed29358d14becc46bebd0e1f1487791587980d4b64159039bfde85b3324342 SPA112.cfg"
diff --git a/community/acf-provisioning-cisco/SPA112.cfg b/community/acf-provisioning-cisco/SPA112.cfg
new file mode 100644
index 0000000000..bc2a92c245
--- /dev/null
+++ b/community/acf-provisioning-cisco/SPA112.cfg
@@ -0,0 +1,6 @@
+<flat-profile>
+<Upgrade_Enable ua="na">Yes</Upgrade_Enable>
+<Upgrade_Error_Retry_Delay ua="na">7200</Upgrade_Error_Retry_Delay>
+<Downgrade_Rev_Limit ua="na"></Downgrade_Rev_Limit>
+<Upgrade_Rule ua="na">http://$SERV/Cisco/SPA112_SPA122_1.3.1_003.bin</Upgrade_Rule>
+</flat-profile>
diff --git a/community/acf-provisioning-cisco/init.cfg b/community/acf-provisioning-cisco/init.cfg
new file mode 100644
index 0000000000..b6cce7dec0
--- /dev/null
+++ b/community/acf-provisioning-cisco/init.cfg
@@ -0,0 +1,4 @@
+<flat-profile>
+<Provision_Enable ua="na">Yes</Provision_Enable>
+<Profile_Rule ua="na">http://$SERV/$PN.cfg</Profile_Rule>
+</flat-profile>
diff --git a/community/acf-provisioning-cyberdata/000000cd.xml b/community/acf-provisioning-cyberdata/000000cd.xml
new file mode 100644
index 0000000000..cfc585de20
--- /dev/null
+++ b/community/acf-provisioning-cyberdata/000000cd.xml
@@ -0,0 +1,6 @@
+<specific>
+ <FirmwareSettings>
+ <OutdoorIntercom31>CyberData/1148-uImage-outdoor_intercom</OutdoorIntercom31>
+ <OutdoorKeypad31>CyberData/1148-uImage-outdoor_keypad</OutdoorKeypad31>
+ </FirmwareSettings>
+</specific>
diff --git a/community/acf-provisioning-cyberdata/APKBUILD b/community/acf-provisioning-cyberdata/APKBUILD
new file mode 100644
index 0000000000..e803d3622a
--- /dev/null
+++ b/community/acf-provisioning-cyberdata/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Seung Soo Mun <hamletmun@gmail.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-cyberdata
+pkgver=11.4.8
+pkgrel=0
+pkgdesc="Files for provisioning CyberData Outdoor Intercom"
+url="http://www.cyberdata.net/products/voip/digitalanalog/intercom_endpoints.html"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+source="http://www.cyberdata.net/assets/011186/1148-uImage-outdoor_intercom.zip
+http://www.cyberdata.net/assets/011214/1148-uImage-outdoor_keypad.zip
+000000cd.xml"
+
+subpackages=""
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/CyberData
+ cp 000000cd.xml "$pkgdir"/var/www/provisioning/htdocs/
+ cp *intercom/*intercom "$pkgdir"/var/www/provisioning/htdocs/CyberData
+ cp *keypad/*keypad "$pkgdir"/var/www/provisioning/htdocs/CyberData
+ cp *keypad/autoprovision_* "$pkgdir"/var/www/provisioning/htdocs/CyberData/initial.xml.sample
+}
+
+md5sums="5914a25c9e5fbc6ed856ab1edf391cb9 1148-uImage-outdoor_intercom.zip
+a253b328d0dd41b7aea112bcd13ebb9a 1148-uImage-outdoor_keypad.zip
+656e8bf591f1df6e73c9bd4d5986e72f 000000cd.xml"
+sha256sums="c92109422097e466b5d5b16dca5f851f0a0aefe2535b49192e10c33447d64ccc 1148-uImage-outdoor_intercom.zip
+54947d3e5a618e4e1e447284a736b41888ff2a8fd5ea415d322f37482c852603 1148-uImage-outdoor_keypad.zip
+e86ad2ae19a8435e7829c359550f3aefe1461118cc27663493702cb7697d2104 000000cd.xml"
+sha512sums="a39255a9eb0d73719a260289c003de4a2d045327ebfaa5c61cfa033f4e025dfb89b4c06196450aa81c26f57476af1accb1420e4f317e20e746ecc568b8e40360 1148-uImage-outdoor_intercom.zip
+aec4a247c4d91dc2c942a91c55e2a1415a42fad881701f47cc368f5f3311160fb49380cf059700a49bf73a7c606c79cdda54765b994ce46c312cb65dd4499b39 1148-uImage-outdoor_keypad.zip
+69d7179464f404c7ef07b1ebf72fed49bdea95d630b52101b27167237093a01c6554008519b95786b1d178773317d5734892033179fd5f1d0080df4609d2b077 000000cd.xml"
diff --git a/community/acf-provisioning-linksys/APKBUILD b/community/acf-provisioning-linksys/APKBUILD
new file mode 100644
index 0000000000..d22e10a7cc
--- /dev/null
+++ b/community/acf-provisioning-linksys/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Ted Trask <ttrask01@yahoo.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-linksys
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Files for provisioning Cisco Linksys IP phones"
+url="http://www.cisco.com/en/US/products/ps10029/index.html"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+source="http://download.cisco.com/swc/esd/03/282414114/anon/PAP2T_v5.1.6_fw.zip
+init.cfg
+PAP2T.cfg"
+subpackages=""
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Linksys
+ cp *.cfg *.bin "$pkgdir"/var/www/provisioning/htdocs/Linksys
+}
+
+md5sums="c35ffdd7c60372305e59bf376362b022 PAP2T_v5.1.6_fw.zip
+4c826d078240d8e64ba084ea811a65d1 init.cfg
+69c7febeb502bf159c69a94258c3b84d PAP2T.cfg"
diff --git a/community/acf-provisioning-linksys/PAP2T.cfg b/community/acf-provisioning-linksys/PAP2T.cfg
new file mode 100644
index 0000000000..770b147571
--- /dev/null
+++ b/community/acf-provisioning-linksys/PAP2T.cfg
@@ -0,0 +1,6 @@
+<flat-profile>
+<Upgrade_Enable ua="na">Yes</Upgrade_Enable>
+<Upgrade_Error_Retry_Delay ua="na">7200</Upgrade_Error_Retry_Delay>
+<Downgrade_Rev_Limit ua="na"></Downgrade_Rev_Limit>
+<Upgrade_Rule ua="na">http://$SERV/Linksys/pap2t-5-1-6.bin</Upgrade_Rule>
+</flat-profile>
diff --git a/community/acf-provisioning-linksys/init.cfg b/community/acf-provisioning-linksys/init.cfg
new file mode 100644
index 0000000000..b6cce7dec0
--- /dev/null
+++ b/community/acf-provisioning-linksys/init.cfg
@@ -0,0 +1,4 @@
+<flat-profile>
+<Provision_Enable ua="na">Yes</Provision_Enable>
+<Profile_Rule ua="na">http://$SERV/$PN.cfg</Profile_Rule>
+</flat-profile>
diff --git a/community/acf-provisioning-polycom/000000000000-directory.xml b/community/acf-provisioning-polycom/000000000000-directory.xml
new file mode 100644
index 0000000000..2c5fecabea
--- /dev/null
+++ b/community/acf-provisioning-polycom/000000000000-directory.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" standalone="yes"?>
+<directory>
+ <item_list/>
+</directory>
diff --git a/community/acf-provisioning-polycom/000000000000-phone.cfg b/community/acf-provisioning-polycom/000000000000-phone.cfg
new file mode 100644
index 0000000000..f3fe583345
--- /dev/null
+++ b/community/acf-provisioning-polycom/000000000000-phone.cfg
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<!-- Application SIP Wolverine 3.3.1.0933 02-Feb-11 18:44 -->
+<PHONE_CONFIG>
+ <OVERRIDES />
+</PHONE_CONFIG>
diff --git a/community/acf-provisioning-polycom/000000000000-web.cfg b/community/acf-provisioning-polycom/000000000000-web.cfg
new file mode 100644
index 0000000000..f3fe583345
--- /dev/null
+++ b/community/acf-provisioning-polycom/000000000000-web.cfg
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<!-- Application SIP Wolverine 3.3.1.0933 02-Feb-11 18:44 -->
+<PHONE_CONFIG>
+ <OVERRIDES />
+</PHONE_CONFIG>
diff --git a/community/acf-provisioning-polycom/000000000000.cfg.patch b/community/acf-provisioning-polycom/000000000000.cfg.patch
new file mode 100644
index 0000000000..405527a607
--- /dev/null
+++ b/community/acf-provisioning-polycom/000000000000.cfg.patch
@@ -0,0 +1,30 @@
+--- src/000000000000.cfg
++++ src/000000000000.cfg.new
+@@ -3,18 +3,15 @@
+ <!-- For information on configuring Polycom VoIP phones please refer to the -->
+ <!-- Configuration File Management white paper available from: -->
+ <!-- http://www.polycom.com/common/documents/whitepapers/configuration_file_management_on_soundpoint_ip_phones.pdf -->
+-<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="" MISC_FILES="" LOG_FILE_DIRECTORY="" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="" USER_PROFILES_DIRECTORY="" CALL_LISTS_DIRECTORY="" COREFILE_DIRECTORY="">
+- <APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_213.ld" CONFIG_FILES_SPIP300="phone1_213.cfg, sip_213.cfg"/>
+- <APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_213.ld" CONFIG_FILES_SPIP500="phone1_213.cfg, sip_213.cfg"/>
+- <APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301="phone1_318.cfg, sip_318.cfg"/>
++<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="Polycom/[PHONE_MAC_ADDRESS]-default.cfg, Polycom/initial.cfg" MISC_FILES="" LOG_FILE_DIRECTORY="log" OVERRIDES_DIRECTORY="Polycom" CONTACTS_DIRECTORY="Polycom" LICENSE_DIRECTORY="Polycom" USER_PROFILES_DIRECTORY="Polycom" CALL_LISTS_DIRECTORY="Polycom" COREFILE_DIRECTORY="Polycom">
++ <APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_213.ld" CONFIG_FILES_SPIP300=""/>
++ <APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_213.ld" CONFIG_FILES_SPIP500=""/>
++ <APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301=""/>
+ <APPLICATION_SPIP320 APP_FILE_PATH_SPIP320="sip_335.ld" CONFIG_FILES_SPIP320=""/>
+ <APPLICATION_SPIP330 APP_FILE_PATH_SPIP330="sip_335.ld" CONFIG_FILES_SPIP330=""/>
+- <APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_327.ld" CONFIG_FILES_SPIP430="phone1_327.cfg, sip_327.cfg"/>
+- <APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501="phone1_318.cfg, sip_318.cfg"/>
+- <APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600="phone1_318.cfg, sip_318.cfg"/>
+- <APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601="phone1_318.cfg, sip_318.cfg"/>
+- <APPLICATION_SPIP670 APP_FILE_PATH_SPIP670="sip_404.ld" CONFIG_FILES_SPIP670=""/>
+- <APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000="phone1_318.cfg, sip_318.cfg"/>
+- <APPLICATION_SSIP6000 APP_FILE_PATH_SSIP6000="sip_404.ld" CONFIG_FILES_SSIP6000=""/>
+- <APPLICATION_SSIP7000 APP_FILE_PATH_SSIP7000="sip_404.ld" CONFIG_FILES_SSIP7000=""/>
++ <APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_327.ld" CONFIG_FILES_SPIP430=""/>
++ <APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501=""/>
++ <APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600=""/>
++ <APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601=""/>
++ <APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000=""/>
+ </APPLICATION>
diff --git a/community/acf-provisioning-polycom/APKBUILD b/community/acf-provisioning-polycom/APKBUILD
new file mode 100644
index 0000000000..7ad4e28f45
--- /dev/null
+++ b/community/acf-provisioning-polycom/APKBUILD
@@ -0,0 +1,106 @@
+# Contributor: Ted Trask <ttrask01@yahoo.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-polycom
+pkgver=5.3.2
+pkgrel=0
+pkgdesc="Files for provisioning Polycom IP phones"
+url="http://www.polycom.com/products/voice/index.html"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+# Make sure 5.3.2 comes after 4.0.8c so that older files are overwritten
+source="http://downloads.polycom.com/voice/voip/uc/Polycom_UC_Software_4_0_8_Rev_C_release_sig_split.zip
+http://downloads.polycom.com/voice/voip/uc/SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig.zip
+http://downloads.polycom.com/voice/voip/uc/Polycom_UC_Software_5_3_2_release_sig_split.zip
+000000000000.cfg.patch
+000000000000-phone.cfg
+000000000000-web.cfg
+000000000000-directory.xml"
+subpackages=""
+
+_builddir="$srcdir/"
+
+link_dupes() {
+ local dir=
+ local old_pwd="$PWD"
+ for dir; do
+ echo "Creating links of duplicate files at '$dir'"
+ cd "$dir" || break
+ prevsum=
+ prevfile=
+ md5sum *.ld | sort | while read sum file; do
+ if [ "$sum" = "$prevsum" ]; then
+ echo "* Creating link of '$file'"
+ rm $file && ln -s $prevfile $file || break
+ else
+ prevsum=$sum
+ prevfile=$file
+ fi
+ done || break
+ done
+ local ret=$?
+ cd "$old_pwd"
+ return $ret
+}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ sed -i -e 's/\r//' 000000000000.cfg
+ for i in $source; do
+ case $i in
+ *.patch) msg "Applying ${i}"; patch -p1 -i $i || return 1;;
+ esac
+ done
+}
+
+package() {
+ cd "$_builddir"
+ link_dupes "$_builddir" || return 1
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Polycom
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/log
+ echo "$pkgname-$pkgver-r$pkgrel" > "$pkgdir"/var/www/provisioning/htdocs/Polycom/package-version
+ cp -r *.ld *.wav SoundPointIPLocalization VVXLocalization 000000000000.cfg "$pkgdir"/var/www/provisioning/htdocs
+ cp 000000000000-directory.xml 000000000000-phone.cfg 000000000000-web.cfg "$pkgdir"/var/www/provisioning/htdocs/Polycom
+}
+
+# unpack the sources
+default_unpack() {
+ local u
+ if [ -z "$force" ]; then
+ verify || return 1
+ initdcheck || return 1
+ fi
+ mkdir -p "$srcdir"
+ for u in $source; do
+ local s="$SRCDEST/$(filename_from_uri $u)"
+ case "$s" in
+ *.zip)
+ msg "Unpacking $s..."
+ unzip -o "$s" -d "$srcdir" || return 1;;
+ esac
+ done
+}
+
+md5sums="be6364402a35d4fc3f38d817a2bd5117 Polycom_UC_Software_4_0_8_Rev_C_release_sig_split.zip
+b5ac28a1b4ede82fca226675c0b6981d SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig.zip
+be7694a0c852f528f4a17627d4cb1547 Polycom_UC_Software_5_3_2_release_sig_split.zip
+a567851b650cf3e7a20f26ec3f63bf75 000000000000.cfg.patch
+2c32486b7c9d692326fd6270664eac01 000000000000-phone.cfg
+2c32486b7c9d692326fd6270664eac01 000000000000-web.cfg
+4a6ff93b944a710da0c3eb99938f42cc 000000000000-directory.xml"
+sha256sums="b2ffe49f306b071b9e04e1049b4293dda06e8e1e5c27fd129af31ec535cbd381 Polycom_UC_Software_4_0_8_Rev_C_release_sig_split.zip
+4565248f354321901323d01b1aeed8bb6e00beedc331a3f7545cbae83d194113 SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig.zip
+eb8ddb122888996189525c5bba3ad076aa78eb8e551cc17ce9959bd198fb6dff Polycom_UC_Software_5_3_2_release_sig_split.zip
+81346cdbafcd6e370debde74a2894ea93e777cff631b27321f3bf7300329bb60 000000000000.cfg.patch
+e2f3dcd842d6eb44a98140e7fb60487ca70e519d5d09872a54ce1372d5a432b4 000000000000-phone.cfg
+e2f3dcd842d6eb44a98140e7fb60487ca70e519d5d09872a54ce1372d5a432b4 000000000000-web.cfg
+875f5bbec057d29508bcd671a203d8e2852cd959aeaeb937443cedbe824e0a41 000000000000-directory.xml"
+sha512sums="1ca4b9975948f2266e299aa6a27c29554898af04ad07f6a76b6033b95473f915c4d96c132e9ab67cc32613f95a4433129f05a7c125dbd3a53b9c393e68c0e871 Polycom_UC_Software_4_0_8_Rev_C_release_sig_split.zip
+b624b6618af41c21de016ead0746be9702834632e32de1bd62a5b47ad2308f0fb9def72fcfb35259731b7431d00a958e9c4ad3ad7d7257a29bba9e976dc70c4c SoundPoint_IP_BootROM_4_4_0B_Upgrader_release_sig.zip
+ecee627af77d41b3bce6b55c2908bbe85e78a494dc2cf925d5bae2eb033da1517e3e5601e3219a5a75fd8c1857b72bc62848d86283a0c6ea68abae17fc81306f Polycom_UC_Software_5_3_2_release_sig_split.zip
+8ec2605c84f8e5db50fff0ed842dc965a10457d72d9672b176b680d5599e93947c0c6011513cacc84ff5f324df573d38e09ac7301b27f6dcac40af3c56392639 000000000000.cfg.patch
+db2da0f4c393bdea773f3e5a7daa581a58caca738538db6153b223383176aae30e2081c198291d78c44eddd446a1cab9cffef78646360847ce4955c59f288300 000000000000-phone.cfg
+db2da0f4c393bdea773f3e5a7daa581a58caca738538db6153b223383176aae30e2081c198291d78c44eddd446a1cab9cffef78646360847ce4955c59f288300 000000000000-web.cfg
+9adc73d02aa4f545aca893c335284d77099c56fcc17a48f61003ede8713e96aeb8f467896f4dfbf7db67255cc3d60faf353b76ab86c5881d0ba884d1c0acffb3 000000000000-directory.xml"
diff --git a/community/acf-provisioning-snom/APKBUILD b/community/acf-provisioning-snom/APKBUILD
new file mode 100644
index 0000000000..c651e80a68
--- /dev/null
+++ b/community/acf-provisioning-snom/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Ted Trask <ttrask01@yahoo.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-snom
+pkgver=8.4.32
+pkgrel=0
+pkgdesc="Files for provisioning Snom IP phones"
+url="http://snom.com/"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+source="http://provisioning.snom.com/download/fw/snom300-$pkgver-SIP-f.bin
+http://provisioning.snom.com/download/fw/snom320-$pkgver-SIP-f.bin
+http://provisioning.snom.com/download/fw/snom360-$pkgver-SIP-f.bin
+http://provisioning.snom.com/download/fw/snom370-$pkgver-SIP-f.bin
+http://fox.snom.com/config/snomlang-$pkgver.zip
+snom300-firmware.htm
+snom320-firmware.htm
+snom360-firmware.htm
+snom370-firmware.htm"
+subpackages=""
+
+prepare() {
+ local i
+ cd "$srcdir"
+ for i in $source; do
+ case $i in
+ *.htm) sed -i "s/\$pkgver/$pkgver/" $i || return 1;;
+ esac
+ done
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/snom
+ cp *.htm *.bin *.xml "$pkgdir"/var/www/provisioning/htdocs/snom
+}
+
+md5sums="799ac33cb2ee11b92fe96fb7e49caca8 snom300-8.4.32-SIP-f.bin
+bf9c500215ef4a9da9041f54d52b273f snom320-8.4.32-SIP-f.bin
+9aa96d2a337fb28df3412dea0e87d411 snom360-8.4.32-SIP-f.bin
+faead904596d7713bf32ee21de33d0a0 snom370-8.4.32-SIP-f.bin
+fb60b9b6dc82fcbef663b873bd37bff9 snomlang-8.4.32.zip
+8b577e049488d735c576db6034b4fade snom300-firmware.htm
+9ad50f693de113559b973742c294bbc5 snom320-firmware.htm
+af7aa9844f0e03c54e13c5a09de3fdbe snom360-firmware.htm
+42be37d51edcacc2804b8a6dda9dc333 snom370-firmware.htm"
diff --git a/community/acf-provisioning-snom/snom300-firmware.htm b/community/acf-provisioning-snom/snom300-firmware.htm
new file mode 100644
index 0000000000..dd5c2c3c68
--- /dev/null
+++ b/community/acf-provisioning-snom/snom300-firmware.htm
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<firmware-settings>
+ <firmware perm="">http://$SERV/snom/snom300-$pkgver-SIP-f.bin</firmware>
+</firmware-settings>
diff --git a/community/acf-provisioning-snom/snom320-firmware.htm b/community/acf-provisioning-snom/snom320-firmware.htm
new file mode 100644
index 0000000000..39ba8bc626
--- /dev/null
+++ b/community/acf-provisioning-snom/snom320-firmware.htm
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<firmware-settings>
+ <firmware perm="">http://$SERV/snom/snom320-$pkgver-SIP-f.bin</firmware>
+</firmware-settings>
diff --git a/community/acf-provisioning-snom/snom360-firmware.htm b/community/acf-provisioning-snom/snom360-firmware.htm
new file mode 100644
index 0000000000..2488d1ce2f
--- /dev/null
+++ b/community/acf-provisioning-snom/snom360-firmware.htm
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<firmware-settings>
+ <firmware perm="">http://$SERV/snom/snom360-$pkgver-SIP-f.bin</firmware>
+</firmware-settings>
diff --git a/community/acf-provisioning-snom/snom370-firmware.htm b/community/acf-provisioning-snom/snom370-firmware.htm
new file mode 100644
index 0000000000..45754c3811
--- /dev/null
+++ b/community/acf-provisioning-snom/snom370-firmware.htm
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="utf-8" ?>
+<firmware-settings>
+ <firmware perm="">http://$SERV/snom/snom370-$pkgver-SIP-f.bin</firmware>
+</firmware-settings>