aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-12 15:21:44 +0100
committerprspkt <prspkt@protonmail.com>2019-06-21 02:06:05 +0300
commit710ef760e53456633ba59da7a223741804c49e88 (patch)
treea3193b2a827b5140a91831e7ceff1ce8011c85f0 /community
parentdc538e7917e64404a1bec06c75f6f58804cbe1ea (diff)
downloadaports-710ef760e53456633ba59da7a223741804c49e88.tar.bz2
aports-710ef760e53456633ba59da7a223741804c49e88.tar.xz
community/py3-cachetools: upgrade to 3.1.0
- pure python package so remove dependency on -dev - change _pkgname to _pyname to match <https://wiki.alpinelinux.org/wiki/Python_package_policies>
Diffstat (limited to 'community')
-rw-r--r--community/py3-cachetools/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/community/py3-cachetools/APKBUILD b/community/py3-cachetools/APKBUILD
index 25b05397c5..8ce09b9599 100644
--- a/community/py3-cachetools/APKBUILD
+++ b/community/py3-cachetools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-cachetools
-_pkgname=cachetools
-pkgver=2.1.0
+_pyname=cachetools
+pkgver=3.1.0
pkgrel=1
pkgdesc="Extensible memoizing collections and decorators"
url="https://github.com/tkem/cachetools"
@@ -10,23 +10,19 @@ arch="noarch"
license="MIT"
depends="python3"
checkdepends="py3-pytest"
-makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/tkem/cachetools/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/$_pyname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 -m pytest .
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="359f0b57c34af96d4c8cfac19daa591e357db19c592ce89449001593f3044affb6e6109e1d2b63666dd8c95c6c496387032759d2ef01e5d5ae93eef39df15d72 py3-cachetools-2.1.0.tar.gz"
+sha512sums="b11d517047da0b56f8de375ae640c112de26c0ee6b71ca4a644fc455b96b2f26c96c7f756fa2c0550b79803011de55ecf9d78e4f6839bf5f9bcb72a5681413c0 py3-cachetools-3.1.0.tar.gz"