aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-04-10 15:29:39 -0500
committerAndy Postnikov <apostnikov@gmail.com>2019-04-12 22:05:29 +0300
commit7d6c914981c4415148989504d8f82615723d93fb (patch)
tree6ece52956d2425d8cfae5ba383e2376de4eacd22 /community
parent3267ee639c46ab2fa84f4844799352b75cfb9d1d (diff)
downloadaports-7d6c914981c4415148989504d8f82615723d93fb.tar.bz2
aports-7d6c914981c4415148989504d8f82615723d93fb.tar.xz
community/cython: symlink cython to cython3
- rename binaries to cython2 and cython3 - choose cython3 as the default binary
Diffstat (limited to 'community')
-rw-r--r--community/cython/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/community/cython/APKBUILD b/community/cython/APKBUILD
index ce1ed7ab69..69af28a116 100644
--- a/community/cython/APKBUILD
+++ b/community/cython/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=cython
pkgver=0.29.6
-pkgrel=0
+pkgrel=1
pkgdesc="Cython is an optimising static compiler for both the Python & the extended Cython programming languages."
url="https://cython.org"
arch="all"
@@ -45,11 +45,20 @@ package() {
_py2() {
cd "$builddir"-py2
_py python2
+
+ local f; for f in cygdb cython cythonize; do
+ mv "$subpkgdir"/usr/bin/$f "$subpkgdir"/usr/bin/${f}2
+ done
}
_py3() {
cd "$builddir"
_py python3
+
+ local f; for f in cygdb cython cythonize; do
+ mv "$subpkgdir"/usr/bin/$f "$subpkgdir"/usr/bin/${f}3
+ ln -s ${f}3 "$subpkgdir"/usr/bin/$f
+ done
}
_py() {