aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-28 09:04:08 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-06 14:07:04 +0000
commit8cd0bf973bb38d32988b452f28e37440b29891da (patch)
treecbd7510ee1b05634fb4e27d99e5a8d5f6b63c30a /community
parent5eec8d62760cb08f88428fcb3adff65422526bf5 (diff)
downloadaports-8cd0bf973bb38d32988b452f28e37440b29891da.tar.bz2
aports-8cd0bf973bb38d32988b452f28e37440b29891da.tar.xz
community/qt5-qtusb: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/qt5-qtusb/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/qt5-qtusb/APKBUILD b/community/qt5-qtusb/APKBUILD
new file mode 100644
index 0000000000..9716dbc7cb
--- /dev/null
+++ b/community/qt5-qtusb/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=qt5-qtusb
+pkgver=0.6.2
+pkgrel=0
+pkgdesc="Qt5 - a cross-platform USB Module for Qt."
+url="https://github.com/fpoussin/QtUsb/"
+arch="all"
+license="LGPL-3.0-only"
+options="!check" # at the moment "make install" is needed for it to work
+makedepends="hidapi-dev libusb-dev qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fpoussin/QtUsb/archive/$pkgver.tar.gz"
+builddir="$srcdir/QtUsb-$pkgver"
+
+build() {
+ qmake-qt5
+ make
+}
+
+check() {
+ cd tests
+ qmake-qt5
+ make -i check TESTARGS="-o result.xml,xunitxml"
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="65f7213fa7d3b09c7923cdea13bc6c261040418bd9b93ac25891cdb198069e7a02ba6c60dd5f67eaf97cac4ffcea3047b3187969d95eabcc2c01987a871cd0cf qt5-qtusb-0.6.2.tar.gz"