aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:27:07 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:32 -0300
commit8e252e641f2e753ac86d53db19c338bf528a545b (patch)
treed46eaca456319304086e2daf4a68a298d4c33183 /community
parent5ffb449d02928fccaccb951a07ef873baf4c067b (diff)
downloadaports-8e252e641f2e753ac86d53db19c338bf528a545b.tar.bz2
aports-8e252e641f2e753ac86d53db19c338bf528a545b.tar.xz
community/kgamma5: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/kgamma5/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/kgamma5/APKBUILD b/community/kgamma5/APKBUILD
new file mode 100644
index 0000000000..28c0d8ffd0
--- /dev/null
+++ b/community/kgamma5/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kgamma5
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Adjust your monitor's gamma settings"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="GPL-2.0-or-later"
+makedepends="qt5-qtbase-dev kconfig-dev kconfigwidgets-dev kdoctools-dev ki18n-dev extra-cmake-modules"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="0cbf4162dec3653710f9e2c8cbeb2e7c6780a3fac75f0abd3c63124ac538d8bec065fbadf0765155e77954be4b7c7375e565c1c834e5bc775fcb8dfad677328a kgamma5-5.16.5.tar.xz"