aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-08 22:28:03 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-09 11:55:49 +0100
commit987f73e1996298ba984f3422e7489bb86fd45b26 (patch)
tree3767216c9433ae9d896f8139f4284ff126152804 /community
parentcda2953723a3bbc4802976945de933aa0ead9bf5 (diff)
downloadaports-987f73e1996298ba984f3422e7489bb86fd45b26.tar.bz2
aports-987f73e1996298ba984f3422e7489bb86fd45b26.tar.xz
community/aisleriot: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/aisleriot/APKBUILD38
-rw-r--r--community/aisleriot/fix-bash-shebang.patch10
2 files changed, 48 insertions, 0 deletions
diff --git a/community/aisleriot/APKBUILD b/community/aisleriot/APKBUILD
new file mode 100644
index 0000000000..8e17adf36e
--- /dev/null
+++ b/community/aisleriot/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+pkgname="aisleriot"
+pkgver="3.22.10"
+pkgrel=3
+pkgdesc="Solitaire and other card games for GNOME"
+url="https://wiki.gnome.org/Apps/Aisleriot"
+arch="all !s390x"
+license="GPL-3.0-or-later"
+depends="guile"
+makedepends="meson bash librsvg-dev guile-dev libxml2 libxml2-dev libxml2-utils
+ itstool gtk+3.0-dev libcanberra-dev gmp-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://gitlab.gnome.org/GNOME/aisleriot/-/archive/$pkgver/aisleriot-$pkgver.tar.gz
+ fix-bash-shebang.patch"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ -D theme_kde=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="c041fcf51949b5e0b6e0a1efb5665e0853537694e5fc35ac15f4f41d6133c56e078fcd92710da0cce957432883a7cea636698c3fc4e83e54262c25273c551eb3 aisleriot-3.22.10.tar.gz
+9db40fb258e8d70de8d1763eaf08fc1c9b79291efff8018556f2a18d40dd66c0f73b37083199bee6e41130766b91b124e539afed2a8ccde8105e34a0bc8f1f43 fix-bash-shebang.patch"
diff --git a/community/aisleriot/fix-bash-shebang.patch b/community/aisleriot/fix-bash-shebang.patch
new file mode 100644
index 0000000000..d4b12988ca
--- /dev/null
+++ b/community/aisleriot/fix-bash-shebang.patch
@@ -0,0 +1,10 @@
+diff --git a/cards/meson_svgz.sh b/cards/meson_svgz.sh
+index 5a0bf01..20f0de9 100755
+--- a/cards/meson_svgz.sh
++++ b/cards/meson_svgz.sh
+@@ -1,4 +1,4 @@
+-#!/usr/bin/bash
++#!/usr/bin/env bash
+ # Copyright © 2019 Christian Persch
+ #
+ # This programme is free software; you can redistribute it and/or modify it