aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:42:44 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:08:00 +0100
commit9dfd1a4e27b2cc60755502c439b1b9fde00da55e (patch)
treedb3fe45e1f7c35fae17da4ea770e5929c29177f0 /community
parent3aa5a63c4e9459266d34ba117fa75adae3c6de4f (diff)
downloadaports-9dfd1a4e27b2cc60755502c439b1b9fde00da55e.tar.bz2
aports-9dfd1a4e27b2cc60755502c439b1b9fde00da55e.tar.xz
community/gnome-games: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/gnome-games/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/gnome-games/APKBUILD b/community/gnome-games/APKBUILD
new file mode 100644
index 0000000000..981f3cdada
--- /dev/null
+++ b/community/gnome-games/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-games
+pkgver=3.34.2
+pkgrel=0
+pkgdesc="Browser and play your games"
+url="https://wiki.gnome.org/Apps/Games"
+arch="all !s390x" # needs librsvg
+license="GPL-3.0-or-later"
+makedepends="meson gtk+3.0-dev vala grilo-dev libhandy-dev librsvg-dev libmanette-dev
+ libsoup-dev tracker-dev sqlite-dev libxml2-dev libarchive-dev retro-gtk-dev"
+checkdepends="desktop-file-utils appstream-glib"
+subpackages="$pkgname-lang"
+source="https://download.gnome.org/sources/gnome-games/${pkgver%.*}/gnome-games-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="df83535f253306b0399843fe899487079244a3640e72a0a85a0221cebf595c2bbf27fa4fc1182e529004a656e30d346eb6c30a9c19c2fbf45cefc8517ab30c86 gnome-games-3.34.2.tar.xz"