aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-19 19:34:52 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-21 15:26:59 +0100
commit9e720648fbe2ba938d28f85e846666699957ccc6 (patch)
treea3a204f5fe570cd1333019ae448b1a178aadb3a1 /community
parent28bc974f9463b206e3404fbe9c0701ab8f8e264e (diff)
downloadaports-9e720648fbe2ba938d28f85e846666699957ccc6.tar.bz2
aports-9e720648fbe2ba938d28f85e846666699957ccc6.tar.xz
community/rust: upgrade to 1.40.0
Diffstat (limited to 'community')
-rw-r--r--community/rust/APKBUILD10
-rw-r--r--community/rust/alpine-change-rpath-to-rustlib.patch3
-rw-r--r--community/rust/rustdoc-fix-conflicting-symbols.patch35
3 files changed, 6 insertions, 42 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 3f59b25637..1a7f47d012 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -4,9 +4,9 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=rust
-pkgver=1.39.0
+pkgver=1.40.0
_llvmver=9
-_bootver=1.38.0
+_bootver=1.39.0
pkgrel=0
pkgdesc="The Rust Programming Language"
url="https://www.rust-lang.org"
@@ -71,7 +71,6 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
musl-dont-use-crt-static.patch
0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
alpine-change-rpath-to-rustlib.patch
- rustdoc-fix-conflicting-symbols.patch
"
builddir="$srcdir/rustc-$pkgver-src"
@@ -313,7 +312,7 @@ _mv() {
mv "$@"
}
-sha512sums="77be74410b9f7a2e9f78f7a9860964e122ab9518553acc2cc80d5abeecf3302e9b3ed1fd29e022cccff1f9ff4a568b4015c0d3ac0a524f06e38e9cb360a3341e rustc-1.39.0-src.tar.gz
+sha512sums="8afdb7fddbc5f2cec05fe962cd425ff8f3f41b056ffc983135d21d5c7d217084a1d73b4f9e4ff12faf7731ff1332d2889b71eed0a5216dd5eff5302d26b33d1e rustc-1.40.0-src.tar.gz
8d52048070e9a158810f5ef71eae07a3b107b60986375a593c3509f4c47f8e2f7fcdff8bc558c03c46127dbf66c4077dd7b5b422a83f2c49fb5d52ecfae5697e musl-fix-static-linking.patch
41fd9e8a8dd99074d95d664e65f92dba644b8ef9fa37b9a1d781a01fe49eaa254c430f0f277622dc4f8203aad2d129a045fdf1679a0da526d549fac60654be26 musl-fix-linux_musl_base.patch
97e81c57af93df550577f41d795185a9eb0c37528776c250076cc57f06c87e81139eb71cd6b6a4730528511821ae50c304d7deb534d6422cd08bb44193ae605d static-pie.patch
@@ -326,5 +325,4 @@ c31fdfe8a9b3411576c75da46645cf0465b9053000a2ab49cf9b2f2733f679d6d33acbf236d67a20
2a91c0d149f19a2268b2db8e375e0c10820529f588161d8d8e68900d929235d9b1cb4f0d64539c1e20ecca3948b4715f2d9d3d16a2754373d56b4b5808bed6bd link-musl-dynamically.patch
795194976763326c5e4a9eefc8b651b6d5fb533d2d000631ed48a92bafac90e9ca33b8d662e6c53ef109ea1a90c69def715d7d7154e3f9fb9035a58a313a7db3 musl-dont-use-crt-static.patch
f15c8e6a4c8ad33ee5874580ed76463e2a7359e9b4a8651eb974ea5354c3f992fd2ce1d04661ee8cff2105b25967428894ecdd144a6a45f09c7e1952b2f3731c 0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
-7755637b140c5ddf01a8805b74b1b71a7e581c32d7deabf1372a94ccec30b6c494603cd5ab362f429b8b537ff4f7ee22de1b1ff43d5131c9130216319464773f alpine-change-rpath-to-rustlib.patch
-0cbe98e34e765b567502f0c7d502f19d9efb7722c82df4cabefc7948f53be73a69427f2fab00ce33cb43de5502c736bf48b7dfdf2dd2306137338e62e839e197 rustdoc-fix-conflicting-symbols.patch"
+f1b956fd1367b09a959367ee4f61b77d88e2b445d2b778080f9f0b1ef0bd8c65edd993faad45ef355f92d60ca3d62029d92cdf52fbe7b2a979add829bedb4d6b alpine-change-rpath-to-rustlib.patch"
diff --git a/community/rust/alpine-change-rpath-to-rustlib.patch b/community/rust/alpine-change-rpath-to-rustlib.patch
index 8e3e018500..cf2be834a4 100644
--- a/community/rust/alpine-change-rpath-to-rustlib.patch
+++ b/community/rust/alpine-change-rpath-to-rustlib.patch
@@ -24,7 +24,7 @@ Related upstream issues:
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
-@@ -967,11 +967,11 @@
+@@ -989,12 +989,12 @@
// so. Note that this is definitely a hack, and we should likely
// flesh out rpath support more fully in the future.
rustflags.arg("-Zosx-rpath-install-name");
@@ -32,6 +32,7 @@ Related upstream issues:
+ Some("-Wl,-rpath,@loader_path/../lib".to_string())
} else if !target.contains("windows") &&
!target.contains("wasm32") &&
+ !target.contains("emscripten") &&
!target.contains("fuchsia") {
- Some("-Wl,-rpath,$ORIGIN/../lib")
+ Some(format!("-Wl,-rpath,$ORIGIN/../lib/rustlib/{}/lib", target))
diff --git a/community/rust/rustdoc-fix-conflicting-symbols.patch b/community/rust/rustdoc-fix-conflicting-symbols.patch
deleted file mode 100644
index b399b16bf9..0000000000
--- a/community/rust/rustdoc-fix-conflicting-symbols.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 73369f32621f6a844a80a8513ae3ded901e4a406 Mon Sep 17 00:00:00 2001
-From: Mark Rousskov <mark.simulacrum@gmail.com>
-Date: Tue, 5 Nov 2019 11:16:46 -0500
-Subject: [PATCH] Hopefully fix rustdoc build
-
-It's super unclear why this broke when we switched to beta but not
-previously -- but at least it's hopefully fixed now.
----
- src/bootstrap/builder.rs | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index 2748903f2d47..2edcef203ad2 100644
---- a/src/bootstrap/builder.rs
-+++ b/src/bootstrap/builder.rs
-@@ -886,7 +886,18 @@ impl<'a> Builder<'a> {
- // things still build right, please do!
- match mode {
- Mode::Std => metadata.push_str("std"),
-- _ => {},
-+ // When we're building rustc tools, they're built with a search path
-+ // that contains things built during the rustc build. For example,
-+ // bitflags is built during the rustc build, and is a dependency of
-+ // rustdoc as well. We're building rustdoc in a different target
-+ // directory, though, which means that Cargo will rebuild the
-+ // dependency. When we go on to build rustdoc, we'll look for
-+ // bitflags, and find two different copies: one built during the
-+ // rustc step and one that we just built. This isn't always a
-+ // problem, somehow -- not really clear why -- but we know that this
-+ // fixes things.
-+ Mode::ToolRustc => metadata.push_str("tool-rustc"),
-+ _ => {}
- }
- cargo.env("__CARGO_DEFAULT_LIB_METADATA", &metadata);
-