aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-08 12:31:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-08 12:32:15 +0000
commitadc2c2a9186a9afa52eabca6f3067ba3efb9b92d (patch)
treecfb21dc16b9781ef2525eb5ec9548af49d2117ee /community
parent0905d093856a9727b68783a3fe9cea30f5d86fcc (diff)
downloadaports-adc2c2a9186a9afa52eabca6f3067ba3efb9b92d.tar.bz2
aports-adc2c2a9186a9afa52eabca6f3067ba3efb9b92d.tar.xz
community/moreutils: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/moreutils/APKBUILD37
-rw-r--r--community/moreutils/docbook-xsl.patch11
2 files changed, 48 insertions, 0 deletions
diff --git a/community/moreutils/APKBUILD b/community/moreutils/APKBUILD
new file mode 100644
index 0000000000..0a15ec8e51
--- /dev/null
+++ b/community/moreutils/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=moreutils
+pkgver=0.62
+pkgrel=1
+pkgdesc="A growing collection of the unix tools that nobody thought to write thirty years ago"
+url="https://joeyh.name/code/moreutils/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="perl perl-timedate perl-ipc-run"
+checkdepends="bash"
+makedepends="perl-dev docbook-xsl docbook-xml perl-xml-sax libxslt-dev linux-headers"
+subpackages="$pkgname-doc"
+source="http://ftp.de.debian.org/debian/pool/main/m/moreutils/moreutils_$pkgver.orig.tar.xz
+ docbook-xsl.patch"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=$pkgdir/usr install
+ chmod 0644 $pkgdir/usr/share/man/man1/*
+ mv $pkgdir/usr/share/man/man1/ts.1 $pkgdir/usr/share/man/man1/ts.1moreutils
+ mv $pkgdir/usr/share/man/man1/parallel.1 $pkgdir/usr/share/man/man1/parallel-moreutils.1
+ mv $pkgdir/usr/bin/parallel $pkgdir/usr/bin/parallel-moreutils
+}
+
+sha512sums="4d1bd481695f3152d33fbb8a58ca923c70ad0a189df7272082adb8d2ccaf0349a3816b6e0f642b667faa36935e4098ed4d2b40dfd256f84b7d5c48e9ace0bdc2 moreutils_0.62.orig.tar.xz
+38c0088c2c637ac1cc809c16b7a2fb386a67d88a7aca2aef458203de3599fe6258c80ab0b5edfbb534203d71510c4d37abe4ebe23427273a4ccecf305736c9e3 docbook-xsl.patch"
diff --git a/community/moreutils/docbook-xsl.patch b/community/moreutils/docbook-xsl.patch
new file mode 100644
index 0000000000..e10f90e608
--- /dev/null
+++ b/community/moreutils/docbook-xsl.patch
@@ -0,0 +1,11 @@
+--- a/Makefile 2017-02-19 20:44:09.469193976 +0100
++++ b/Makefile 2017-02-19 20:44:32.302484346 +0100
+@@ -8,7 +8,7 @@
+ ifneq (,$(findstring CYGWIN,$(shell uname)))
+ DOCBOOKXSL?=/usr/share/sgml/docbook/xsl-stylesheets
+ else
+- DOCBOOKXSL?=/usr/share/xml/docbook/stylesheet/docbook-xsl
++ DOCBOOKXSL?=/usr/share/xml/docbook/xsl-stylesheets-1.79.1
+ endif
+
+ DOCBOOK2XMAN=xsltproc --param man.authors.section.enabled 0 $(DOCBOOKXSL)/manpages/docbook.xsl