aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-10-22 15:31:23 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 11:36:40 -0300
commitb4905bfefc29439631941824996fd6f76b3cac37 (patch)
treeed6220d4c35ba07736d1cf7c000ed761da027f31 /community
parentbbd36c8bd08ca860c38f2629d4ea8dde9465d6f6 (diff)
downloadaports-b4905bfefc29439631941824996fd6f76b3cac37.tar.bz2
aports-b4905bfefc29439631941824996fd6f76b3cac37.tar.xz
community/py3-automat: upgrade to 0.8.0
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community')
-rw-r--r--community/py3-automat/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
index 82f8e049b7..d79ba8df67 100644
--- a/community/py3-automat/APKBUILD
+++ b/community/py3-automat/APKBUILD
@@ -3,19 +3,27 @@
# Maintainer: Tiago Ilieve <tiago.myhro@gmail.com>
pkgname=py3-automat
_pkgname=Automat
-pkgver=0.7.0
-pkgrel=2
+pkgver=0.8.0
+pkgrel=0
pkgdesc="Self-service finite-state machines for the programmer on the go"
url="https://automat.readthedocs.io/"
arch="noarch"
license="MIT"
depends="py3-attrs py3-six"
-makedepends="py3-setuptools py3-incremental pytest py3-graphviz py3-twisted"
+makedepends="py3-setuptools"
+checkdepends="py3-graphviz py3-twisted pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-automat" # Backwards compatibility
-provides="py-automat=$pkver-r$pkgrel" # Backwards compatibility
+provides="py-automat=$pkgver-r$pkgrel" # Backwards compatibility
+
+prepare() {
+ sed -i setup.py \
+ -e "/print(/d" \
+ -e "/setup_requires=/,+3d" \
+ -e "s/use_scm_version=True/version='${pkgver}'/"
+}
build() {
python3 setup.py build
@@ -28,4 +36,5 @@ check() {
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74 Automat-0.7.0.tar.gz"
+
+sha512sums="2dbd4e784f65b02a8c93fc5f15236df3649d667a9792f6cac929dbac5d971495bdab4825df0fcd6817b9a9f79b7a5d8cfbdf8e4d18605f0761546b31b3091ad7 Automat-0.8.0.tar.gz"