aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:42:37 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:08:00 +0100
commitb5091664ab11972da58b8c14bcc4378cd44cdb5d (patch)
tree7f002ad464445d7cbdcbe04b17e0b643f6c9585e /community
parent49657020b1b8bb1f1ab0aa9d2eac69964a7738a9 (diff)
downloadaports-b5091664ab11972da58b8c14bcc4378cd44cdb5d.tar.bz2
aports-b5091664ab11972da58b8c14bcc4378cd44cdb5d.tar.xz
community/libmanette: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/libmanette/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libmanette/APKBUILD b/community/libmanette/APKBUILD
new file mode 100644
index 0000000000..741a89f257
--- /dev/null
+++ b/community/libmanette/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=libmanette
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="Simple GObject game controller library"
+url="https://gitlab.gnome.org/aplazas/libmanette"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="meson glib-dev libgudev-dev libevdev-dev gobject-introspection-dev
+ vala"
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/libmanette/${pkgver%.*}/libmanette-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="23d3feae3b0ba81deb75b0ff911eb37f3d0d767a0ae65815d34cadf69f78ca7f081177a2161105ea3979ba9222b3641e6b776bf4fcf3e46a9de716bdce475df6 libmanette-0.2.3.tar.xz"