aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-27 02:00:24 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-28 13:11:26 +0000
commitbbdc6eb8430581f107bc23e05559eb485a8fc154 (patch)
tree0a8ddf10b9ec70139db2f18391741066b48d6f41 /community
parent55c22575d57e17c72f708ebc7e58d7370924fb56 (diff)
downloadaports-bbdc6eb8430581f107bc23e05559eb485a8fc154.tar.bz2
aports-bbdc6eb8430581f107bc23e05559eb485a8fc154.tar.xz
main/boost: bump dependent aports
Diffstat (limited to 'community')
-rw-r--r--community/anytun/APKBUILD14
-rw-r--r--community/anytun/fix-iostream.patch10
-rw-r--r--community/anytun/fix-werror-compile-flags.patch2
-rw-r--r--community/bitcoin/APKBUILD2
-rw-r--r--community/gource/APKBUILD2
-rw-r--r--community/icinga2/APKBUILD2
-rw-r--r--community/innoextract/APKBUILD2
-rw-r--r--community/libcmis/APKBUILD2
-rw-r--r--community/libixion/APKBUILD2
-rw-r--r--community/liborcus/APKBUILD2
-rw-r--r--community/libreoffice/APKBUILD2
-rw-r--r--community/mkvtoolnix/APKBUILD2
-rw-r--r--community/mongodb/APKBUILD2
-rw-r--r--community/pdns-recursor/APKBUILD2
-rw-r--r--community/pdns/APKBUILD2
-rw-r--r--community/tomahawk/APKBUILD2
16 files changed, 28 insertions, 24 deletions
diff --git a/community/anytun/APKBUILD b/community/anytun/APKBUILD
index b7c7b95040..684cca0201 100644
--- a/community/anytun/APKBUILD
+++ b/community/anytun/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=anytun
pkgver=0.3.6
-pkgrel=4
+pkgrel=5
pkgdesc="Secure anycast tunneling protocol implementation for flexible and fault-tolerant VPNs"
url="http://www.anytun.org"
arch="all"
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-doc"
source="http://www.anytun.org/download/$pkgname-$pkgver.tar.gz
boost-mt.patch
fix-werror-compile-flags.patch
+ fix-iostream.patch
$pkgname.initd"
_builddir="$srcdir"/$pkgname-$pkgver/src
@@ -47,15 +48,8 @@ package() {
install -Dm 755 "$srcdir"/$pkgname.initd "${pkgdir}"/etc/init.d/$pkgname
}
-md5sums="90683b03a3f438639c5f2de0730dcf5e anytun-0.3.6.tar.gz
-d7220eae296c814ee100d8ca1f5cf19a boost-mt.patch
-3122d09abb4d8f24043e11bdbf5b8229 fix-werror-compile-flags.patch
-d429ba9feaaf15bb268b811eccc71862 anytun.initd"
-sha256sums="afef9ba3002df9d1bd2eba2ec2ab9a9551a0822bfa9664bfbc3c97a6e2e313a8 anytun-0.3.6.tar.gz
-31dca9b29da41ed338d12ff96171b1f2a84013f689af0965c2d97f2fbcf0b499 boost-mt.patch
-a07966d0866dc18b88682fffa3892535ed6422cb1200c7bdbeec2a019a8a34b4 fix-werror-compile-flags.patch
-f2390be3b27d2a208e4d77bf776d62c2dd9a92a79a30e5394188b82af6f55037 anytun.initd"
sha512sums="470bec0ed96fd8cd7921d8a110272578020b666e8852c9e52a88da9957b2d641cd2b43cc8c9e453331a9f848282ea4516e304d71add6fea71a7ce3e6d76117b1 anytun-0.3.6.tar.gz
e19522a26529bb16591ed724d499c3b7fd7060e937eadc93f7719c29aaa604b953c59b94024efe2227331741ba5bbde084619dd42071cf086ef803906e6678a7 boost-mt.patch
-f9705cf1879a8f50bc53fae04b48a88baa9aa5f7f1035b0ec737bdacaa21007da76b8985e1b9cba05936c9dc94200cb3c4ff39492755c8f219e42ee73ecf1431 fix-werror-compile-flags.patch
+e2f23ed7183f7636716946458b108a7055beb190a89d462d815d164f61a5c52b268620f053e5bb169c48d4e9cd56ad2f1d3d65a23a202375ef13998c29f4fdf6 fix-werror-compile-flags.patch
+4d1115733f8d3d467bdd6348df451dfb60bff45685406792514717d27a567e323f76b12b4406a6d784f20716c08b596d6c09842c60e81c67fdaf8b0eed9b7530 fix-iostream.patch
a31455058e0ac60ed9457c79eea789ce19ba49abc200b59c0d8390eb0c3b6f09813177f9b679fb8ac69ac7b0be862e4604d19298ae4cd79925511fff3963e93d anytun.initd"
diff --git a/community/anytun/fix-iostream.patch b/community/anytun/fix-iostream.patch
new file mode 100644
index 0000000000..12dffd8d6d
--- /dev/null
+++ b/community/anytun/fix-iostream.patch
@@ -0,0 +1,10 @@
+--- a/src/routingTreeNode.cpp.orig 2018-03-27 19:30:45.345569478 +0300
++++ b/src/routingTreeNode.cpp 2018-03-27 19:30:53.217662424 +0300
+@@ -44,6 +44,7 @@
+ */
+
+ #include "routingTreeNode.h"
++#include <iostream>
+
+ RoutingTreeNode::RoutingTreeNode():mux_(0),valid_(false)
+ {
diff --git a/community/anytun/fix-werror-compile-flags.patch b/community/anytun/fix-werror-compile-flags.patch
index 919a74b24e..5720a7d115 100644
--- a/community/anytun/fix-werror-compile-flags.patch
+++ b/community/anytun/fix-werror-compile-flags.patch
@@ -8,7 +8,7 @@ index 65a0c74..357628e 100755
if [ $USE_CLANG -eq 0 ]; then
- CXXFLAGS='-g -Wall -Werror -Wno-error=unused-variable -O2'
- LDFLAGS='-g -Wall -Werror -O2'
-+ CXXFLAGS='-g -Wall -Wno-error=unused-variable -O2'
++ CXXFLAGS='-g -Wall -Wno-error=unused-variable -O2 -DBOOST_SYSTEM_ENABLE_DEPRECATED'
+ LDFLAGS='-g -Wall -O2'
COMPILER='g++'
else
diff --git a/community/bitcoin/APKBUILD b/community/bitcoin/APKBUILD
index 1fc0cc7aec..7de29be580 100644
--- a/community/bitcoin/APKBUILD
+++ b/community/bitcoin/APKBUILD
@@ -3,7 +3,7 @@
pkgname=bitcoin
pkgver=0.16.0
_ver=${pkgver/_/}
-pkgrel=0
+pkgrel=1
pkgdesc="decentralized P2P electronic cash system"
url="http://www.bitcoin.org/"
arch="all !armhf"
diff --git a/community/gource/APKBUILD b/community/gource/APKBUILD
index d0b46479b2..e5b24ab419 100644
--- a/community/gource/APKBUILD
+++ b/community/gource/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gource
pkgver=0.47
-pkgrel=1
+pkgrel=2
pkgdesc="Software version control visualization"
url="http://gource.io/"
arch="all"
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 0bfe5774d9..df253ca188 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.8.2
-pkgrel=0
+pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
arch="all !armhf"
diff --git a/community/innoextract/APKBUILD b/community/innoextract/APKBUILD
index 707222a12c..feb719756e 100644
--- a/community/innoextract/APKBUILD
+++ b/community/innoextract/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
pkgname=innoextract
pkgver=1.6
-pkgrel=2
+pkgrel=3
pkgdesc="A tool to extract installers created by Inno Setup"
url="http://constexpr.org/innoextract/"
arch="all"
diff --git a/community/libcmis/APKBUILD b/community/libcmis/APKBUILD
index 1a36546676..d1f67eaf9f 100644
--- a/community/libcmis/APKBUILD
+++ b/community/libcmis/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libcmis
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="CMIS protocol client library"
url="https://sourceforge.net/projects/libcmis/"
arch="all"
diff --git a/community/libixion/APKBUILD b/community/libixion/APKBUILD
index 00e0e936a2..a0ba2ce420 100644
--- a/community/libixion/APKBUILD
+++ b/community/libixion/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libixion
pkgver=0.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="a general purpose formula parser & interpreter"
url="https://gitlab.com/ixion/ixion"
arch="all"
diff --git a/community/liborcus/APKBUILD b/community/liborcus/APKBUILD
index e4b29202c6..30d2c3ad94 100644
--- a/community/liborcus/APKBUILD
+++ b/community/liborcus/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=liborcus
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="Library for processing spreadsheet documents"
url="https://gitlab.com/orcus/orcus"
arch="all"
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index 14368c9f2e..9a5e0e4dd5 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libreoffice
pkgver=5.4.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="LibreOffice - Meta package for the full office suite"
url="http://www.libreoffice.org/"
arch="all !s390x"
diff --git a/community/mkvtoolnix/APKBUILD b/community/mkvtoolnix/APKBUILD
index 7d904633c9..68845496c5 100644
--- a/community/mkvtoolnix/APKBUILD
+++ b/community/mkvtoolnix/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=mkvtoolnix
pkgver=21.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Set of tools to create, edit and inspect Matroska files"
url="https://mkvtoolnix.download/index.html"
arch="all"
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index d75feec7cd..6d4aaf41c1 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Marc Vertes <mvertes@free.fr>
pkgname=mongodb
pkgver=3.6.3
-pkgrel=1
+pkgrel=2
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64'
diff --git a/community/pdns-recursor/APKBUILD b/community/pdns-recursor/APKBUILD
index ac25c46aaa..27201a5fa4 100644
--- a/community/pdns-recursor/APKBUILD
+++ b/community/pdns-recursor/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Olivier Mauras <olivier@mauras.ch>
pkgname=pdns-recursor
pkgver=4.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="PowerDNS Recursive Server"
url="https://www.powerdns.com/"
arch="all !s390x"
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index 18b7dbdca4..c86049a1f2 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -6,7 +6,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=pdns
pkgver=4.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="PowerDNS Authoritative Server"
url="https://www.powerdns.com/"
arch="all"
diff --git a/community/tomahawk/APKBUILD b/community/tomahawk/APKBUILD
index 4025934706..dfdebc128a 100644
--- a/community/tomahawk/APKBUILD
+++ b/community/tomahawk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=tomahawk
pkgver=0.8.4
-pkgrel=8
+pkgrel=9
pkgdesc="A Music Player App written in C++/Qt"
url="http://tomahawk-player.org/"
arch="all"