aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 14:40:06 +0100
committerKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 14:40:06 +0100
commitc3db2c658e240402eae6c52403055ae63d43ed5e (patch)
tree8b831f59380e1352447d4695aa6ea29446d97bd9 /community
parent2338ae52a383729046c5d094846ea13fd86c86ec (diff)
downloadaports-c3db2c658e240402eae6c52403055ae63d43ed5e.tar.bz2
aports-c3db2c658e240402eae6c52403055ae63d43ed5e.tar.xz
community/vint: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/vint/01-python3-shebang.patch8
-rw-r--r--community/vint/APKBUILD30
2 files changed, 38 insertions, 0 deletions
diff --git a/community/vint/01-python3-shebang.patch b/community/vint/01-python3-shebang.patch
new file mode 100644
index 0000000000..c642296321
--- /dev/null
+++ b/community/vint/01-python3-shebang.patch
@@ -0,0 +1,8 @@
+--- a/bin/vint
++++ b/bin/vint
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import sys
+ from pathlib import Path
diff --git a/community/vint/APKBUILD b/community/vint/APKBUILD
new file mode 100644
index 0000000000..3e7b12d467
--- /dev/null
+++ b/community/vint/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=vint
+pkgver=0.3.21
+pkgrel=0
+pkgdesc="Fast and Highly Extensible Vim script Language Lint"
+url="https://github.com/Kuniwak/vint"
+arch="noarch"
+license="MIT"
+depends="python3 py3-yaml py3-chardet py3-ansicolor py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov py3-coverage"
+# no tests in artifact on PyPI
+source="$pkgname-$pkgver.tar.gz::https://github.com/Kuniwak/vint/archive/v$pkgver.tar.gz
+ 01-python3-shebang.patch
+ "
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="47e832d382952cb16bcc233eefa1f06ca74f95eb445d7f96d6804391b91a2c8a8e7b749b7f33f65aed9d3bdc1ff5e5332a62c3935969395f16a854f0f66e383b vint-0.3.21.tar.gz
+e777c74ffc16964848f22f051281a284fa05774bd7be9417ea5ad033ea9bc264687df10151e08bf5d319aa7168481e5dd8e3366a942af4fe739ef64511268fa4 01-python3-shebang.patch"