aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-13 22:27:49 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-14 15:45:17 +0000
commitc938788518994884e65fcf16a2af605cab8f2b36 (patch)
tree86ace346147d40ebb07fb9cc10a4803a96f21bbe /community
parent34280d68efe2228db461b5a9e1bec0759022d2e3 (diff)
downloadaports-c938788518994884e65fcf16a2af605cab8f2b36.tar.bz2
aports-c938788518994884e65fcf16a2af605cab8f2b36.tar.xz
community/kdepim-runtime: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/kdepim-runtime/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/kdepim-runtime/APKBUILD b/community/kdepim-runtime/APKBUILD
new file mode 100644
index 0000000000..90e46c45d5
--- /dev/null
+++ b/community/kdepim-runtime/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdepim-runtime
+pkgver=19.12.3
+pkgrel=0
+pkgdesc="Extends the functionality of kdepim"
+url="https://kontact.kde.org/"
+# armhf blocked by extra-cmake-modules
+# mips, ppc64le and s390x blocked by libkgapi -> qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !mips !mips64"
+license="LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtspeech-dev qt5-qtxmlpatterns-dev qt5-qtnetworkauth-dev qca-dev kconfig-dev kconfigwidgets-dev knotifyconfig-dev kio-dev kitemmodels-dev kcodecs-dev kwindowsystem-dev ktextwidgets-dev knotifications-dev kdoctools-dev kholidays-dev akonadi-dev kmime-dev akonadi-mime-dev kmailtransport-dev kidentitymanagement-dev akonadi-contacts-dev kcontacts-dev kcalendarcore-dev kcalutils-dev kmbox-dev kimap-dev akonadi-notes-dev akonadi-calendar-dev pimcommon-dev libkgapi-dev kdav-dev libxslt-dev shared-mime-info"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kdepim-runtime-$pkgver.tar.xz"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make -C build
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C build install
+}
+
+sha512sums="0a851ac588ac8b78f31344712badcf8770e5d1effe488aaa70baf695034bfa75fd08d6a2b30fa43856b800f9d016551213960495ba1ef4687ae38f88fad08b3b kdepim-runtime-19.12.3.tar.xz"