aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-29 16:10:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 16:26:09 +0100
commitce391085c0c4694b51156c2212eaec20484b66b1 (patch)
tree145264df9999b258c6b5cc5b26a2d975adb132cc /community
parentea85ca34b7aa97d996503d561b7fb94e5d1458a1 (diff)
downloadaports-ce391085c0c4694b51156c2212eaec20484b66b1.tar.bz2
aports-ce391085c0c4694b51156c2212eaec20484b66b1.tar.xz
community/mongodb-tools: upgrade to 4.2.1
Diffstat (limited to 'community')
-rw-r--r--community/mongodb-tools/APKBUILD8
-rw-r--r--community/mongodb-tools/fix-cstruct-decls.patch78
2 files changed, 3 insertions, 83 deletions
diff --git a/community/mongodb-tools/APKBUILD b/community/mongodb-tools/APKBUILD
index b3614a3e22..6a3b6977ef 100644
--- a/community/mongodb-tools/APKBUILD
+++ b/community/mongodb-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Marc Vertes <mvertes@free.fr>
# Maintainer: Marc Vertes <mvertes@free.fr>
pkgname=mongodb-tools
-pkgver=4.0.6
-pkgrel=2
+pkgver=4.2.1
+pkgrel=0
pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
url="https://github.com/mongodb/mongo-tools"
arch="all !s390x"
@@ -10,7 +10,6 @@ license="Apache-2.0"
makedepends="$depends_dev go cyrus-sasl-dev openssl-dev libpcap-dev bash perl"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo-tools/archive/r$pkgver.tar.gz
- fix-cstruct-decls.patch
fix-build.patch
"
builddir="$srcdir/src/github.com/mongodb/mongo-tools"
@@ -34,6 +33,5 @@ package() {
"$bindir"
}
-sha512sums="d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7 mongodb-tools-4.0.6.tar.gz
-e95ff1c3583ad8c3c4b8f14c6743fe8a5029c91e83b78bc33eae762d1d3aa48a6536c5b27183fca81b93034f4f3d91d23fef857a1f85f725d57f3a45a599fedf fix-cstruct-decls.patch
+sha512sums="bba754acd9e21f8f832fc2e434720347c2222897b2af08d66f9491110d5491f5475ae2118ff25b263606677da10b0c96b76cc507a01287180096c25c1eab5ced mongodb-tools-4.2.1.tar.gz
74e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch"
diff --git a/community/mongodb-tools/fix-cstruct-decls.patch b/community/mongodb-tools/fix-cstruct-decls.patch
deleted file mode 100644
index 87d332c5b5..0000000000
--- a/community/mongodb-tools/fix-cstruct-decls.patch
+++ /dev/null
@@ -1,78 +0,0 @@
---- a/vendor/github.com/google/gopacket/pcap/pcap.go
-+++ b/vendor/github.com/google/gopacket/pcap/pcap.go
-@@ -170,7 +170,7 @@
- // BPF is a compiled filter program, useful for offline packet matching.
- type BPF struct {
- orig string
-- bpf _Ctype_struct_bpf_program // takes a finalizer, not overriden by outsiders
-+ bpf C.struct_bpf_program // takes a finalizer, not overriden by outsiders
- }
-
- // BPFInstruction is a byte encoded structure holding a BPF instruction
-@@ -381,7 +381,7 @@
-
- // Stats returns statistics on the underlying pcap handle.
- func (p *Handle) Stats() (stat *Stats, err error) {
-- var cstats _Ctype_struct_pcap_stat
-+ var cstats C.struct_pcap_stat
- if -1 == C.pcap_stats(p.cptr, &cstats) {
- return nil, p.Error()
- }
-@@ -418,7 +418,7 @@
- return datalinks, nil
- }
-
--func (p *Handle) compileBPFFilter(expr string) (_Ctype_struct_bpf_program, error) {
-+func (p *Handle) compileBPFFilter(expr string) (C.struct_bpf_program, error) {
- errorBuf := (*C.char)(C.calloc(errorBufferSize, 1))
- defer C.free(unsafe.Pointer(errorBuf))
-
-@@ -441,7 +441,7 @@
- }
- }
-
-- var bpf _Ctype_struct_bpf_program
-+ var bpf C.struct_bpf_program
- cexpr := C.CString(expr)
- defer C.free(unsafe.Pointer(cexpr))
-
-@@ -459,7 +459,7 @@
- return nil, err
- }
-
-- bpfInsn := (*[bpfInstructionBufferSize]_Ctype_struct_bpf_insn)(unsafe.Pointer(bpf.bf_insns))[0:bpf.bf_len:bpf.bf_len]
-+ bpfInsn := (*[bpfInstructionBufferSize]C.struct_bpf_insn)(unsafe.Pointer(bpf.bf_insns))[0:bpf.bf_len:bpf.bf_len]
- bpfInstruction := make([]BPFInstruction, len(bpfInsn), len(bpfInsn))
-
- for i, v := range bpfInsn {
-@@ -535,7 +535,7 @@
-
- return nil
- }
--func bpfInstructionFilter(bpfInstructions []BPFInstruction) (bpf _Ctype_struct_bpf_program, err error) {
-+func bpfInstructionFilter(bpfInstructions []BPFInstruction) (bpf C.struct_bpf_program, err error) {
- if len(bpfInstructions) < 1 {
- return bpf, errors.New("bpfInstructions must not be empty")
- }
-@@ -548,7 +548,7 @@
- cbpfInsns := C.calloc(C.size_t(len(bpfInstructions)), C.size_t(unsafe.Sizeof(bpfInstructions[0])))
-
- copy((*[bpfInstructionBufferSize]BPFInstruction)(cbpfInsns)[0:len(bpfInstructions)], bpfInstructions)
-- bpf.bf_insns = (*_Ctype_struct_bpf_insn)(cbpfInsns)
-+ bpf.bf_insns = (*C.struct_bpf_insn)(cbpfInsns)
-
- return
- }
-@@ -656,10 +656,10 @@
- return
- }
-
--func findalladdresses(addresses *_Ctype_struct_pcap_addr) (retval []InterfaceAddress) {
-+func findalladdresses(addresses *C.struct_pcap_addr) (retval []InterfaceAddress) {
- // TODO - make it support more than IPv4 and IPv6?
- retval = make([]InterfaceAddress, 0, 1)
-- for curaddr := addresses; curaddr != nil; curaddr = (*_Ctype_struct_pcap_addr)(curaddr.next) {
-+ for curaddr := addresses; curaddr != nil; curaddr = (*C.struct_pcap_addr)(curaddr.next) {
- // Strangely, it appears that in some cases, we get a pcap address back from
- // pcap_findalldevs with a nil .addr. It appears that we can skip over
- // these.