aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-01-15 12:57:47 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-15 12:57:47 +0100
commitcfec530ff42e784f6508e9321d0e40fd9e108327 (patch)
tree6a88ea438d6c82fea3b5b890f94695dab22629cd /community
parent773fdddd1bc257b0500242d0a82c50ffbcf82c69 (diff)
downloadaports-cfec530ff42e784f6508e9321d0e40fd9e108327.tar.bz2
aports-cfec530ff42e784f6508e9321d0e40fd9e108327.tar.xz
community/lmdb: improve abuild
Diffstat (limited to 'community')
-rw-r--r--community/lmdb/APKBUILD23
1 files changed, 4 insertions, 19 deletions
diff --git a/community/lmdb/APKBUILD b/community/lmdb/APKBUILD
index ed41ed40ee..3bc78ebd77 100644
--- a/community/lmdb/APKBUILD
+++ b/community/lmdb/APKBUILD
@@ -7,33 +7,18 @@ pkgdesc="Lightning Memory-Mapped Database"
url="http://symas.com/mdb/"
arch="all"
license="custom"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://github.com/LMDB/lmdb/archive/LMDB_$pkgver.tar.gz
- lmdb_make.patch
- "
-
-_builddir="$srcdir"/$pkgname-LMDB_$pkgver/libraries/liblmdb
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ lmdb_make.patch"
+builddir="$srcdir/$pkgname-LMDB_$pkgver/libraries/liblmdb"
build() {
- cd "$_builddir"
+ cd "$builddir"
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}