aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-08 21:50:55 +0200
committerprspkt <prspkt@protonmail.com>2019-09-09 00:57:40 +0300
commitd6f2c16186310547f60a0d26081e48d3e9e3e464 (patch)
treef7c079756f20e0688f8a3d55881dedc7634da865 /community
parent5fb2258cfa9dbf4ca32d5efaf372263405f8c506 (diff)
downloadaports-d6f2c16186310547f60a0d26081e48d3e9e3e464.tar.bz2
aports-d6f2c16186310547f60a0d26081e48d3e9e3e464.tar.xz
community/gegl: enable support for more image formats
* fix gexiv2 support (it needs gexiv2, not exiv2) * add support for webp, raw, pango&gdk-pixbuf and much more with ffmpeg * enable vala bindings
Diffstat (limited to 'community')
-rw-r--r--community/gegl/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/community/gegl/APKBUILD b/community/gegl/APKBUILD
index c277316e35..78d4551a3b 100644
--- a/community/gegl/APKBUILD
+++ b/community/gegl/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gegl
pkgver=0.4.16
-pkgrel=2
+pkgrel=3
pkgdesc="Graph based image processing framework"
url="https://www.gegl.org/"
arch="all"
license="GPL-3.0 LGPL-3.0"
makedepends="babl-dev libpng-dev libjpeg-turbo-dev gtk+-dev librsvg-dev
- lua5.1-dev exiv2-dev json-glib-dev"
+ lua5.1-dev gexiv2-dev json-glib-dev libraw-dev libwebp-dev pango-dev
+ gdk-pixbuf-dev ffmpeg-dev vala"
checkdepends="diffutils"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gimp.org/pub/gegl/${pkgver%.*}/gegl-$pkgver.tar.bz2"
@@ -17,9 +18,18 @@ build() {
--build=$CBUILD \
--prefix=/usr \
--disable-docs \
- --with-exiv2 \
+ --with-gexiv2 \
--without-jasper \
- --with-lua
+ --with-lua \
+ --with-vala \
+ --with-pango \
+ --with-cairo \
+ --with-pangocairo \
+ --with-gdk-pixbuf \
+ --with-zlib \
+ --with-librsvg \
+ --with-libraw \
+ --with-webp
make
}