aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNathan Owens <ndowens04@gmail.com>2019-10-25 10:01:54 -0500
committerprspkt <prspkt@protonmail.com>2019-10-27 18:04:08 +0200
commitd8b1d4851abd3397113a23c2f04948d8c856e3a9 (patch)
treef7029cea343c013f696b9fb8a5012723198a520e /community
parent7c4e82a0a0f895d66c939f3706901ab4820d6677 (diff)
downloadaports-d8b1d4851abd3397113a23c2f04948d8c856e3a9.tar.bz2
aports-d8b1d4851abd3397113a23c2f04948d8c856e3a9.tar.xz
community/fossil: upgrade to 2.10
Diffstat (limited to 'community')
-rw-r--r--community/fossil/APKBUILD32
1 files changed, 14 insertions, 18 deletions
diff --git a/community/fossil/APKBUILD b/community/fossil/APKBUILD
index 4585374f2e..d3430bcefe 100644
--- a/community/fossil/APKBUILD
+++ b/community/fossil/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: Paul Onyschuk <blink@bojary.koba.pl>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
-_pkgname="fossil" # upstream name
-pkgname="${_pkgname}"
-pkgver="2.9"
-pkgrel=1
+pkgname="fossil"
+pkgver="2.10"
+pkgrel=0
pkgdesc="Simple, high-reliability, distributed software configuration management"
url="https://www.fossil-scm.org"
arch="all"
license="BSD-2-Clause"
options="!check" # bogus tests
# Final results: 50 errors out of 36205 tests
-depends=""
checkdepends="coreutils ed tcllib"
makedepends="openssl-dev sqlite-dev tcl-dev zlib-dev"
-source="https://www.fossil-scm.org/index.html/uv/${_pkgname}-src-${pkgver}.tar.gz"
-builddir="${srcdir}/${_pkgname}-${pkgver}"
+source="https://www.fossil-scm.org/index.html/uv/fossil-src-$pkgver.tar.gz"
build() {
./configure \
@@ -24,18 +21,18 @@ build() {
--mandir=/usr/share/man \
--json \
--disable-internal-sqlite
- make TCC="${CC:-gcc} ${CFLAGS}"
+ make TCC="${CC:-gcc} $CFLAGS"
}
check() {
- local oldPATH="${PATH}"
- PATH="${PATH}:${builddir}"
- if [ -z "${USER}" ]; then
+ local oldpath="$PATH"
+ PATH="$PATH:$builddir"
+ if [ -z "$USER" ]; then
USER="$(id -u -n)"
export USER
fi
- if [ -z "${HOME}" ]; then
- HOME="$(getent passwd "${USER}" | awk -F : '{print $6; quit;}')"
+ if [ -z "$HOME" ]; then
+ HOME="$(getent passwd "$USER" | awk -F : '{print $6; quit;}')"
export HOME
fi
@@ -44,15 +41,14 @@ check() {
if ! make TESTFLAGS="-quiet -halt" test; then
make test
- PATH="${oldPATH}"
- return 1
+ PATH="$oldpath"
fi
- PATH="${oldPATH}"
+ PATH="$oldpath"
}
package() {
- install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm 755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}
-sha512sums="c3786d4ae5517c88917819448863e9e1e37704a7073a1c87c042660313b77ce3a63f32e35e6a56af1c681e7b8a5acc652b4447d0387b8a8a5b3b5aa04dd9a9b5 fossil-src-2.9.tar.gz"
+sha512sums="aad54e3eaa2d647257c5c723fca4e55981aac0432d3d0b4deaa9651c7db7d27cb9f26f7ff40c31c452cb8dd54b0f0663c632183dc11982bc9cc24adf78b952e5 fossil-src-2.10.tar.gz"