aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-28 09:03:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-06 14:07:04 +0000
commitda6fe780afc62eb9610bfba6280bedcdfd054139 (patch)
treec9398533534c73ceb71cfd9f237f294b44fad782 /community
parent4000c265943846f42894550c517495982fac0aaf (diff)
downloadaports-da6fe780afc62eb9610bfba6280bedcdfd054139.tar.bz2
aports-da6fe780afc62eb9610bfba6280bedcdfd054139.tar.xz
community/qt5-qtscxml: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/qt5-qtscxml/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/qt5-qtscxml/APKBUILD b/community/qt5-qtscxml/APKBUILD
new file mode 100644
index 0000000000..e52443c834
--- /dev/null
+++ b/community/qt5-qtscxml/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qt5-qtscxml
+pkgver=5.14.1
+pkgrel=0
+arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+url="https://www.qt.io/developers/"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+pkgdesc="Static and runtime integration of SCXML models into Qt code"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="$srcdir/qtscxml-everywhere-src-$pkgver"
+
+case $pkgver in
+ *_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
+esac
+
+source="http://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtscxml-everywhere-src-$pkgver.tar.xz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
+}
+sha512sums="92facdc089f7d8c5521617d3080964a12df26e8b34c194be3c9307b412606548d8fda66d401fc6d93f71fed7f1bc7d075f797d4ab27de0ff603608d9b5601c25 qtscxml-everywhere-src-5.14.1.tar.xz"