aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-16 15:50:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-16 16:32:56 -0300
commitdb4d7dc7683054d4d5e52b32821f73bb9a983a30 (patch)
tree814be8d74b0fecdab14aa2f4c21aff22ffa5cdc2 /community
parentf1270747cc6855f83633e980d8ae3fa7426e9700 (diff)
downloadaports-db4d7dc7683054d4d5e52b32821f73bb9a983a30.tar.bz2
aports-db4d7dc7683054d4d5e52b32821f73bb9a983a30.tar.xz
community/bvi: upgrade to 1.4.1
Diffstat (limited to 'community')
-rw-r--r--community/bvi/APKBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/community/bvi/APKBUILD b/community/bvi/APKBUILD
index e47ba646ff..1e62fc8783 100644
--- a/community/bvi/APKBUILD
+++ b/community/bvi/APKBUILD
@@ -1,22 +1,18 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=bvi
-pkgver=1.4.0
-pkgrel=1
+pkgver=1.4.1
+pkgrel=0
pkgdesc="Display-oriented editor for binary files based on vi"
url="http://bvi.sourceforge.net"
arch="all"
-license="GPL-2.0"
-depends=""
+license="GPL-3.0-or-later"
makedepends="ncurses-dev"
-install=""
subpackages="$pkgname-doc"
-source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.src.tar.gz
+source="https://downloads.sourceforge.net/sourceforge/bvi/bvi-$pkgver.src.tar.gz
fix-implicit.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,23 +20,17 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --datadir=/usr/share/doc \
- || return 1
- make || return 1
+ --datadir=/usr/share/doc
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
install -Dm644 CHANGES README CREDITS \
- "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+ "$pkgdir"/usr/share/doc/$pkgname/
}
-md5sums="aa83eb8b2b6b0bb6cdd8e6beef12b775 bvi-1.4.0.src.tar.gz
-dc0499a696dd0419e2df0c743dad4cfe fix-implicit.patch"
-sha256sums="015a3c2832c7c097d98a5527deef882119546287ba8f2a70c736227d764ef802 bvi-1.4.0.src.tar.gz
-8a9ff0895291e9ccfb0cc85867964c9f7bbbe5fdfb8a3e58ab809ac6408e42ff fix-implicit.patch"
-sha512sums="119cfc7350f81c324e77243f948cfb91cd9a3122fef307616e4756a99732f69131aed2a26ebe48048698b9c211a0214255f3e6605ad2cbf479a14a4a0f88923c bvi-1.4.0.src.tar.gz
+sha512sums="f7a3f07e6bcefe566a101c4db85192f0d2e3580be0ab10bc297e6c0192e79d29061a7c9f1a57cf5a628f03962deb8c2ed52e33effc1d5198d458627d70d882e6 bvi-1.4.1.src.tar.gz
b2cb59d82939202df5b12f640182d619cbec25b22aaba0dd9853ee75c7bc285c8f2366d311ebf795e8f78b6daf828545494993f84925fdf4f6d2c12796d9bb32 fix-implicit.patch"