aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:40:17 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:06:59 +0100
commite0506bf825599c06dae0885e976b361148797699 (patch)
tree6708c843d162c8c7daac87c134055309bbeed540 /community
parent3ef4efcf2e2f0384e1a82d670cd52966e04a111b (diff)
downloadaports-e0506bf825599c06dae0885e976b361148797699.tar.bz2
aports-e0506bf825599c06dae0885e976b361148797699.tar.xz
community/iio-sensor-proxy: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/iio-sensor-proxy/0001-Revert-build-Check-for-.pc-files-before-using-them.patch34
-rw-r--r--community/iio-sensor-proxy/APKBUILD45
-rw-r--r--community/iio-sensor-proxy/iio-sensor-proxy.initd4
3 files changed, 83 insertions, 0 deletions
diff --git a/community/iio-sensor-proxy/0001-Revert-build-Check-for-.pc-files-before-using-them.patch b/community/iio-sensor-proxy/0001-Revert-build-Check-for-.pc-files-before-using-them.patch
new file mode 100644
index 0000000000..ddf43770e2
--- /dev/null
+++ b/community/iio-sensor-proxy/0001-Revert-build-Check-for-.pc-files-before-using-them.patch
@@ -0,0 +1,34 @@
+It only needs systemd to determine the unit dir, so delete the dep for now.
+
+From a1c5436d11e3e0dabc3cd236bf8175b13ac929cb Mon Sep 17 00:00:00 2001
+From: Andrea Brancaleoni <abc@pompel.me>
+Date: Fri, 23 Dec 2016 12:43:36 +0100
+Subject: [PATCH] Revert "build: Check for .pc files before using them"
+
+This reverts commit 78b4656fc24a1b21c948d8e68252f42df2a91735.
+---
+ configure.ac | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f8ded66..1d54698 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,14 +25,12 @@ AX_COMPILER_FLAGS([WARN_CFLAGS],[WARN_LDFLAGS])
+
+ GTK_DOC_CHECK([1.11],[--flavour no-tmpl])
+
+-PKG_CHECK_EXISTS(udev, [], [AC_MSG_ERROR(udev development libraries are required)])
+ AC_ARG_WITH([udevrulesdir],
+ AS_HELP_STRING([--with-udevrulesdir=DIR], [Directory for udev rules]),
+ [],
+ [with_udevrulesdir=$($PKG_CONFIG --variable=udevdir udev)"/rules.d"])
+ AC_SUBST([udevrulesdir], [$with_udevrulesdir])
+
+-PKG_CHECK_EXISTS(systemd, [], [AC_MSG_ERROR(systemd development libraries are required)])
+ AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+--
+2.11.0
+
diff --git a/community/iio-sensor-proxy/APKBUILD b/community/iio-sensor-proxy/APKBUILD
new file mode 100644
index 0000000000..de8b196570
--- /dev/null
+++ b/community/iio-sensor-proxy/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=iio-sensor-proxy
+pkgver=2.8
+pkgrel=1
+pkgdesc="IIO sensors to D-Bus proxy"
+url="https://developer.gnome.org/iio-sensor-proxy/1.0/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="eudev-dev libgudev-dev glib-dev autoconf automake libtool gtk+3.0-dev"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="https://github.com/hadess/iio-sensor-proxy/releases/download/$pkgver/iio-sensor-proxy-$pkgver.tar.xz
+ iio-sensor-proxy.initd
+ 0001-Revert-build-Check-for-.pc-files-before-using-them.patch"
+
+prepare() {
+ default_prepare
+ autoreconf -if
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-geoclue-user=geoclue
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="2631ca1bc3fc115d392772010c0e879750cdb1f8d3bb247483527481232c9107212d2c8cbf3bdc30942ef3bd34f4e5c56f168367cafcb8d6381b47ff908014c8 iio-sensor-proxy-2.8.tar.xz
+b0f2875074ff1211faeca3e29b32f60c5604ca31b6dac3d4d99f057ed32e2453aefc4495c34cf3885badacc7168b6c032f3d084052db52977bbe8438e76eac5f iio-sensor-proxy.initd
+5480763f85cb22fd7b1b791609baa3a4b251fc30a025b40aee2de584fa114686bf181a87a249ba4b0cb9080881ff55498baa7e496513bc39fa1af7c43253c465 0001-Revert-build-Check-for-.pc-files-before-using-them.patch"
diff --git a/community/iio-sensor-proxy/iio-sensor-proxy.initd b/community/iio-sensor-proxy/iio-sensor-proxy.initd
new file mode 100644
index 0000000000..73dc96df65
--- /dev/null
+++ b/community/iio-sensor-proxy/iio-sensor-proxy.initd
@@ -0,0 +1,4 @@
+#!/sbin/openrc-run
+
+supervisor=supervise-daemon
+command="/usr/sbin/iio-sensor-proxy"