aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-07 01:43:36 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-07 06:48:44 +0000
commite07704691ff303567e18ba3dce3af65a1c052a1c (patch)
tree4ef003d2ea5fd0ac85132896e43501810f51680b /community
parent29fbdace8842e5114f1c63878d9dda934e615659 (diff)
downloadaports-e07704691ff303567e18ba3dce3af65a1c052a1c.tar.bz2
aports-e07704691ff303567e18ba3dce3af65a1c052a1c.tar.xz
community/quazip: upgrade to 0.9
Diffstat (limited to 'community')
-rw-r--r--community/quazip/APKBUILD11
-rw-r--r--community/quazip/fix-cmake-path.patch11
2 files changed, 4 insertions, 18 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 09b6c49720..2655863e6e 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quazip
-pkgver=0.8.1
-pkgrel=1
+pkgver=0.9
+pkgrel=0
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
options="!check" # Testsuite only available with qmake not cmake
url="https://sourceforge.net/projects/quazip/"
@@ -12,9 +12,7 @@ arch="all"
license="LGPL-2.1-or-later WITH custom-static-linking-exception"
makedepends="qt5-qtbase-dev cmake"
subpackages="$pkgname-dev $pkgname-doc"
-source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/v$pkgver.tar.gz
- fix-cmake-path.patch
- "
+source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/v$pkgver.tar.gz"
replaces="quazip-qt5"
build() {
@@ -32,5 +30,4 @@ package() {
rm -f "$pkgdir"/usr/lib/*.a
}
-sha512sums="d65dab16c2cbc4d8bb23dae5b2fdff5ef787aaff2653b8e75c3fc8ba1701f5568a52bdde39009f83c5069a9fe3331cd1a49cf965822c4180e88bbc341faa2bfb quazip-0.8.1.tar.gz
-430ac7af402812c7d070fae9e8faccc1779e6f95b595970f45cfda07031c2e6038828bcbed1eb11f450291c0d1c409eb852cf540d714db50110fbb84f6f06252 fix-cmake-path.patch"
+sha512sums="8045d36c018bb7bcc39c978bb8f336bad09f21bca4ea5f1327e3ba56d7d01bcc09ee0eca98d7c9065184bf3e15103c4520a81bfbe51286b91a4a82e4f61057f1 quazip-0.9.tar.gz"
diff --git a/community/quazip/fix-cmake-path.patch b/community/quazip/fix-cmake-path.patch
deleted file mode 100644
index 946970fab3..0000000000
--- a/community/quazip/fix-cmake-path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 6fcdd95..71145fe 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
-
- add_subdirectory(quazip)
-
--install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake/Modules)
-+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION lib/cmake/Modules)
-