aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-29 13:21:43 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-29 13:21:49 +0100
commitf1ee04773b81ec9ea05592d0e669cbb04d20cb38 (patch)
tree3435f96cfdc440a6b8f6f08bc09d9be9bc70c703 /community
parent8f22c82065ea51d42bc4693fe71688f4cbfc04e1 (diff)
downloadaports-f1ee04773b81ec9ea05592d0e669cbb04d20cb38.tar.bz2
aports-f1ee04773b81ec9ea05592d0e669cbb04d20cb38.tar.xz
community/wifish: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/wifish/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/wifish/APKBUILD b/community/wifish/APKBUILD
new file mode 100644
index 0000000000..0f85195476
--- /dev/null
+++ b/community/wifish/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=wifish
+pkgver=1.1.4
+pkgrel=1
+pkgdesc="Simple wifi menu tool for wpa_supplicant"
+url="https://github.com/bougyman/wifish"
+options="!check" # Tests require running wpa_supplicant instance with wpa_cli
+arch="noarch"
+license="WTFPL"
+depends="wpa_supplicant gawk dialog"
+checkdepends="checkbashisms"
+source="$pkgname-$pkgver.tar.gz::https://github.com/bougyman/wifish/archive/${pkgver}.tar.gz"
+
+package() {
+ install -Dm777 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd awk
+ for awk in *; do
+ install -Dm644 "$awk" "$pkgdir"/var/lib/wifish/"$awk"
+ done
+}
+
+sha512sums="5315ff3449a5e5162422997ec43946d1f4c441ba436484ae485ba3d6bd3d53f207ddd3d569112b2f1e8eb30f965f80aa5d651f2d07c031d140678274b22beced wifish-1.1.4.tar.gz"