aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-26 06:57:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-26 06:57:38 +0000
commitf3900e1449aa8a98713b67d66e390d9a25927ca2 (patch)
tree93d4cf132706ff3f643460de0c1a578f66fdf293 /community
parent7db1380de5c69c550404c03cd13ef356cef5eab8 (diff)
downloadaports-f3900e1449aa8a98713b67d66e390d9a25927ca2.tar.bz2
aports-f3900e1449aa8a98713b67d66e390d9a25927ca2.tar.xz
community/perl-email-mime-contenttype: update APKBUILD implementing check() function
Diffstat (limited to 'community')
-rw-r--r--community/perl-email-mime-contenttype/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/perl-email-mime-contenttype/APKBUILD b/community/perl-email-mime-contenttype/APKBUILD
index 82eec0db74..85b745f6b2 100644
--- a/community/perl-email-mime-contenttype/APKBUILD
+++ b/community/perl-email-mime-contenttype/APKBUILD
@@ -15,23 +15,27 @@ depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}