aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-19 10:51:35 +0300
committerprspkt <prspkt@protonmail.com>2019-06-19 10:51:35 +0300
commitf6b33bdc71b64535942f4f97aea43e582e624356 (patch)
tree099f6ba9999edccc57c77f58b48cc4fdd1df46b7 /community
parent372d862735a77b6a8cdd952fac80d3270b75a357 (diff)
downloadaports-f6b33bdc71b64535942f4f97aea43e582e624356.tar.bz2
aports-f6b33bdc71b64535942f4f97aea43e582e624356.tar.xz
community/py3-graphviz: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-graphviz/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py3-graphviz/APKBUILD b/community/py3-graphviz/APKBUILD
new file mode 100644
index 0000000000..0c9e801f7a
--- /dev/null
+++ b/community/py3-graphviz/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py3-graphviz
+pkgver=0.11
+pkgrel=0
+pkgdesc="Simple interface for Graphviz"
+url="https://github.com/xflr6/graphviz"
+arch="noarch"
+license="MIT"
+replaces="py-graphviz" # for backwards compatibility
+provides="py-graphviz=$pkgver-r$pkgrel" # for backwards compatibility
+depends="graphviz python3"
+makedepends="py3-setuptools"
+checkdepends="pytest py3-pytest-cov py3-mock py3-pytest-mock"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xflr6/graphviz/archive/$pkgver.tar.gz"
+builddir="$srcdir"/graphviz-$pkgver
+
+build() {
+ python3 setup.py --quiet build
+}
+
+check() {
+ PYTHONPATH=. python3 run-tests.py
+}
+
+package() {
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="84f08b0e143071d23ba34fa7e4104f91135b01b99e04ac1737b5c2699fe10ba36aa1612ce9647826ea9ebfcb4ab566c59b6eba6ae9722d5207b714067eb4d0ea py3-graphviz-0.11.tar.gz"