aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-09-28 03:09:21 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-03 11:46:26 +0200
commitf7d89f85688c8091ee157cb2350c0ed40ba8346e (patch)
tree1c53292e6fcf1e4df09c5702571d41ddcb0dc0ad /community
parentc97e56f90e11fee1c8a8c14f2e4a7d3fe443690d (diff)
downloadaports-f7d89f85688c8091ee157cb2350c0ed40ba8346e.tar.bz2
aports-f7d89f85688c8091ee157cb2350c0ed40ba8346e.tar.xz
community/exim: patch CVE-2019-16928
Diffstat (limited to 'community')
-rw-r--r--community/exim/APKBUILD6
-rw-r--r--community/exim/CVE-2019-16928.patch36
2 files changed, 41 insertions, 1 deletions
diff --git a/community/exim/APKBUILD b/community/exim/APKBUILD
index ab6cb327ed..82fea78bfd 100644
--- a/community/exim/APKBUILD
+++ b/community/exim/APKBUILD
@@ -6,7 +6,7 @@
# Maintainer: Jesse Young <jlyo@jlyo.org>
pkgname=exim
pkgver=4.92.2
-pkgrel=0
+pkgrel=1
pkgdesc="Message Transfer Agent"
url="https://www.exim.org/"
arch="all"
@@ -24,6 +24,7 @@ subpackages="$pkgname-cdb $pkgname-dbmdb $pkgname-dnsdb $pkgname-doc
$pkgname-scripts::noarch $pkgname-sqlite $pkgname-utils
"
source="https://ftp.exim.org/pub/exim/exim4/$pkgname-$pkgver.tar.xz
+ CVE-2019-16928.patch
bounce-charset.patch
exim.Makefile
exim.confd
@@ -32,6 +33,8 @@ source="https://ftp.exim.org/pub/exim/exim4/$pkgname-$pkgver.tar.xz
exim.gencert"
# secfixes:
+# 4.92.2-r1:
+# - CVE-2019-16928
# 4.92.2-r0:
# - CVE-2019-15846
# 4.92.1-r0:
@@ -122,6 +125,7 @@ dbmdb() { _mv_ext dbmdb; }
dnsdb() { _mv_ext dnsdb; }
sha512sums="d27aca4d4e9df267b0afcbe7b3f74c9ca6e96e7e6eb4d2f86ff00b0e2234eaec90271405eb387a36a2e0d4ec5597b2920753f85318a5618ddbc8af475a7d81cd exim-4.92.2.tar.xz
+99cb232ee47f7cb8289662aad1d06df2a268f8c5c00262441e6cc36a0858a82ad22e2fadeabf293b87cc2601f579346176af841080ad40155aaf8d55abfd8f39 CVE-2019-16928.patch
691df92954f015711398350963ea321d143127bc731a985bcacc5364c71b6df84b6c21a2e8dc3cc2048fcd3dd02def3dc8015f4d84dd672f23d5a41348e72dc7 bounce-charset.patch
244676160e13c7a2e4d176789334ad143181176715e4357d99d8b5018f69101b16cbb3c9354ce2b35a514d1f97cc8be654281522c990af721880b80c681ab81a exim.Makefile
bb6f5ead067af19ace661cc92bcd428da97570aedd1f9dc5b61a34e7e3fb3e028be6c96d51df73353bdfcaf69a3ee053fb03d245f868d63ebf518aa96ec82d66 exim.confd
diff --git a/community/exim/CVE-2019-16928.patch b/community/exim/CVE-2019-16928.patch
new file mode 100644
index 0000000000..b920d761e1
--- /dev/null
+++ b/community/exim/CVE-2019-16928.patch
@@ -0,0 +1,36 @@
+From 478effbfd9c3cc5a627fc671d4bf94d13670d65f Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Fri, 27 Sep 2019 12:21:49 +0100
+Subject: [PATCH] Fix buffer overflow in string_vformat. Bug 2449
+
+---
+ src/src/string.c | 4 ++--
+ test/scripts/0000-Basic/0214 | 11 +++++++++++
+ test/stdout/0214 | 7 +++++++
+ 3 files changed, 20 insertions(+), 2 deletions(-)
+
+diff --git a/src/src/string.c b/src/src/string.c
+index c6549bf..3445f8a 100644
+--- a/src/string.c
++++ b/src/string.c
+@@ -1132,7 +1132,7 @@ store_reset(g->s + (g->size = g->ptr + 1));
+ Arguments:
+ g the growable-string
+ p current end of data
+- count amount to grow by
++ count amount to grow by, offset from p
+ */
+
+ static void
+@@ -1590,7 +1590,7 @@ while (*fp)
+ }
+ else if (g->ptr >= lim - width)
+ {
+- gstring_grow(g, g->ptr, width - (lim - g->ptr));
++ gstring_grow(g, g->ptr, width);
+ lim = g->size - 1;
+ gp = CS g->s + g->ptr;
+ }
+--
+1.9.1
+