aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-03-20 09:12:57 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-07 17:55:36 +0000
commitfc8a9dc1bc078b7295a0d842e9766b3b07979536 (patch)
tree17d4a951ca97f3a6e9dde0f9c1839c590a7ea22f /community
parent242c421f6077ae088cb35ca5b282c50b727ea9e4 (diff)
downloadaports-fc8a9dc1bc078b7295a0d842e9766b3b07979536.tar.bz2
aports-fc8a9dc1bc078b7295a0d842e9766b3b07979536.tar.xz
community/dnsdist: cat test-suite.log
Diffstat (limited to 'community')
-rw-r--r--community/dnsdist/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/dnsdist/APKBUILD b/community/dnsdist/APKBUILD
index 32820f5d97..63a159e727 100644
--- a/community/dnsdist/APKBUILD
+++ b/community/dnsdist/APKBUILD
@@ -9,6 +9,7 @@ arch="all"
license="GPL2"
_lua_version="5.1"
depends="$pkgname-common !$pkgname-luajit"
+checkdepends="findutils"
makedepends="boost-dev fstrm-dev libedit-dev libsodium-dev lua${_lua_version}-dev net-snmp-dev protobuf-dev re2-dev"
pkgusers="dnsdist"
pkggroups="dnsdist"
@@ -72,15 +73,21 @@ build() {
make
}
+_cat_found_file() {
+ local _rc="$?"
+ find -name "$1" -type f -ls -printf '%P {{{\n' -exec cat -v -n '{}' ';' -printf '}}} %P\n'
+ return "$_rc"
+}
+
check() {
cd "$builddir"
- make check
+ make check || _cat_found_file 'test-suite.log'
./dnsdist --version
[ -d "$builddir-jit" ] || return 0
cd "$builddir-jit"
- make check
+ make check || _cat_found_file 'test-suite.log'
./dnsdist --version
}