aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-11 06:26:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 06:28:35 -0300
commitfdb787e37fc47078da671decd592dd7c026d415c (patch)
treeae8db742df8136b75eb7b14502965b4c03ea05b6 /community
parentecd9171d0c3cd50d8dee6956f1b5e5cdc3cc33ba (diff)
downloadaports-fdb787e37fc47078da671decd592dd7c026d415c.tar.bz2
aports-fdb787e37fc47078da671decd592dd7c026d415c.tar.xz
community/gotop: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/gotop/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
new file mode 100644
index 0000000000..86b9b86836
--- /dev/null
+++ b/community/gotop/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=gotop
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Terminal based graphical activity monitor"
+url="https://github.com/cjbassi/gotop"
+arch="all"
+license="AGPL-3.0-or-later"
+depends="procps" # Remove once #138 on cjbassi/gotop is fixed
+makedepends="git go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz"
+builddir="$srcdir/src/github.com/cjbassi/gotop"
+
+prepare() {
+ default_prepare
+ mkdir -p "$srcdir"/src/github.com/cjbassi
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+}
+
+build() {
+ GOPATH="$srcdir" go build -v -o bin/$pkgname .
+}
+
+check() {
+ # No testsuite is provided
+ ./bin/$pkgname --help
+}
+
+package() {
+ install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+sha512sums="012cc627fa7013409f3775d5bf2528e25e275fc285fea7ae93a1afec33474c923cc6cd9accb24fce479ab229c98d6438cc9f5eb7dea37f72c1905516d5fdbf6e gotop-3.0.0.tar.gz"