aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-28 12:49:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-28 12:49:26 +0000
commit012936194f25641ce9c748b38ae8985ce6961716 (patch)
tree74aee391b8e1727b068528fc7e284304ab121d85 /main/abuild
parent2254ae034b213a37c1e8bbcdab3d0149ab238597 (diff)
downloadaports-012936194f25641ce9c748b38ae8985ce6961716.tar.bz2
aports-012936194f25641ce9c748b38ae8985ce6961716.tar.xz
main/abuild: fix applying patches from https
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-fix-applying-patches-from-https.patch28
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 32 insertions, 2 deletions
diff --git a/main/abuild/0001-abuild-fix-applying-patches-from-https.patch b/main/abuild/0001-abuild-fix-applying-patches-from-https.patch
new file mode 100644
index 0000000000..a3c65ab97f
--- /dev/null
+++ b/main/abuild/0001-abuild-fix-applying-patches-from-https.patch
@@ -0,0 +1,28 @@
+From bb0324e39824fc0de14fd4b9ad539849ff27c619 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 28 Nov 2019 12:46:12 +0000
+Subject: [PATCH] abuild: fix applying patches from https
+
+fix patches such as https://dev.alpinelinux.org/archive/domoticz/openzwave-1.6.patch
+
+previously it would only work with the filenamename.patch::$url syntax
+---
+ abuild.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/abuild.in b/abuild.in
+index 141cc54..5654d8f 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -682,7 +682,7 @@ default_prepare() {
+ case ${i%::*} in
+ *.patch)
+ msg "${i%::*}"
+- patch ${patch_args:--p1} -i "$srcdir/${i%::*}" || return 1
++ patch ${patch_args:--p1} -i "$srcdir/$(filename_from_uri $i)" || return 1
+ ;;
+ esac
+ done
+--
+2.24.0
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 0043fdf2e5..c8b9a30a2f 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=3.5.0_rc2
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -21,6 +21,7 @@ subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
options="suid !check"
pkggroups="abuild"
source="https://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-abuild-fix-applying-patches-from-https.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -68,4 +69,5 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="7c317d75f8fa64ac2a0674873edc937bcd8fb3d322e5cdf10874fe5ec87fec0ebe3a1d29d50e919376b10135d252659372ffb62e08418158146734fd13f46602 abuild-3.5.0_rc2.tar.xz"
+sha512sums="7c317d75f8fa64ac2a0674873edc937bcd8fb3d322e5cdf10874fe5ec87fec0ebe3a1d29d50e919376b10135d252659372ffb62e08418158146734fd13f46602 abuild-3.5.0_rc2.tar.xz
+7b565481a85a7094a9f61f39ee44ba3c1f3d5bfeed7a5279c57c14447e94f65b613d56d26d197639ab280745e48c51ff7915fd0570a570d29dd7e2490b298dc7 0001-abuild-fix-applying-patches-from-https.patch"