aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-22 12:58:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-22 12:59:26 +0200
commit276fda8e46d3c690947a46fb92ec0940b7b449a4 (patch)
tree1aa558f2491bd20c787178c55de8f43645c5ae90 /main/abuild
parentd84e1cefe9382a476a6f7e141a7a7ff7f9406150 (diff)
downloadaports-276fda8e46d3c690947a46fb92ec0940b7b449a4.tar.bz2
aports-276fda8e46d3c690947a46fb92ec0940b7b449a4.tar.xz
main/abuild: add !checkroot option
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-add-checkroot-option.patch29
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 33 insertions, 2 deletions
diff --git a/main/abuild/0001-add-checkroot-option.patch b/main/abuild/0001-add-checkroot-option.patch
new file mode 100644
index 0000000000..ad9503ed3b
--- /dev/null
+++ b/main/abuild/0001-add-checkroot-option.patch
@@ -0,0 +1,29 @@
+From 79525de509ccb107e388c5f4d5bb700b2d1e8831 Mon Sep 17 00:00:00 2001
+From: Shiz <hi@shiz.me>
+Date: Sat, 20 May 2017 18:32:45 +0200
+Subject: [PATCH] abuild: add !checkroot option to run tests without fakeroot
+
+Due to fakeroot being very permissive with regards to file permissions,
+some package testsuites that explicitly check for failing permission checks
+will fail.
+
+For those testsuites, give the APKBUILD the option to run the tests outside
+of a fakeroot environment.
+---
+ abuild.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/abuild.in b/abuild.in
+index c003282..0f54c87 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1401,6 +1401,9 @@ build_abuildrepo() {
+ # if package() is missing then build is called from rootpkg
+ _build=true
+ fi
++ if options_has "!checkroot"; then
++ _check=check
++ fi
+ if ! want_check; then
+ _check=true
+ fi
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index da115180a8..b5ce3289a3 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=3.0.0_rc2
_ver=${pkgver%_git*}
-pkgrel=7
+pkgrel=8
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -25,6 +25,7 @@ source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
0001-abuild-Add-support-for-lzip-source-packages.patch
0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
+ 0001-add-checkroot-option.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -70,4 +71,5 @@ sha512sums="bb6fa7af3144db99839c24db63e17179d73f659a76c86d530923158b37fad3fcd73e
0e5b64ad175efc4a06197a5e131878e5532539c78ffd8d5aa28a99c9684aa6eec8bc95fdca1c99b916a58c61ddf8d0b7602b1bc9aee276f7a40d82f970c0ad7c 0001-abuild-wrap-check-with-fakeroot.patch
dda641f0ce2bddc8f3d7cf4a3538afe699bda56a5172bd56104de7252796da20025ed36f9401220d8e2fd072297efad94da4be4ed8831e9f9d14ad75c9c8859d 0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
084171ed1e276c02f58dfade28c013d0160fb8a7b87ee03684ffb16c2bb1c64f8b9d98adc947c7b0211ba7fb2d8ef2c590abd9fed80676db52b7829da495d291 0001-abuild-Add-support-for-lzip-source-packages.patch
-51d506f657388215979b551f79a98c46f17c6deba719ec9f0fd7ffc0fd3583fc2870123e309f08c4b7a8958e1742168ec91a57901efc6a72277bb6039807132c 0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch"
+51d506f657388215979b551f79a98c46f17c6deba719ec9f0fd7ffc0fd3583fc2870123e309f08c4b7a8958e1742168ec91a57901efc6a72277bb6039807132c 0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
+6909448e91cd8ba78d0646f550f57562291ef34bcdcef0690166fc7ef145810109836c56cfb086f54ebe6f7dd57ca6968ab532a50217a758a50edf0f9683bf03 0001-add-checkroot-option.patch"