aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-07-22 09:24:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-22 09:24:54 +0000
commit28c03d9717376219368e6a6b52c08d1ebca8c902 (patch)
tree3fb426dd3a2f64765251e743eb77badb125e61aa /main/abuild
parentfe72326fe4f77fde12e4825b6bbe8f92212cf0ef (diff)
downloadaports-28c03d9717376219368e6a6b52c08d1ebca8c902.tar.bz2
aports-28c03d9717376219368e6a6b52c08d1ebca8c902.tar.xz
main/abuild: make default_static depend on depends_static
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-make-default_static-depend-on-depends_static.patch40
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 44 insertions, 2 deletions
diff --git a/main/abuild/0001-make-default_static-depend-on-depends_static.patch b/main/abuild/0001-make-default_static-depend-on-depends_static.patch
new file mode 100644
index 0000000000..b7851bcb06
--- /dev/null
+++ b/main/abuild/0001-make-default_static-depend-on-depends_static.patch
@@ -0,0 +1,40 @@
+From 68a054e274cb7661fc354de62d1ba8d53f2cea02 Mon Sep 17 00:00:00 2001
+From: Leo <thinkabit.ukim@gmail.com>
+Date: Tue, 7 May 2019 02:09:39 -0300
+Subject: [PATCH] make default_static depend on depends_static
+
+keeps it in line with other default_ functions.
+---
+ APKBUILD.5 | 2 ++
+ abuild.in | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/APKBUILD.5 b/APKBUILD.5
+index fe0f833..49b917e 100644
+--- a/APKBUILD.5
++++ b/APKBUILD.5
+@@ -410,6 +410,8 @@ Specifies the run-time dependencies of the -doc subpackage.
+ Specifies the run-time dependencies of the -libs subpackage.
+ .It Cm depends_openrc
+ Specifies the run-time dependencies of the -openrc subpackage.
++.It Cm depends_static
++Specifies the run-time dependencies of the -static subpackage.
+ .It Cm giturl
+ Specifies the URL of the Git repository to use with
+ .Cm abuild checkout .
+diff --git a/abuild.in b/abuild.in
+index 08fce58..1b51e13 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1747,7 +1747,7 @@ dev() {
+ # predefined splitfunc static
+ default_static() {
+ local i=
+- depends=""
++ depends="$depends_static"
+ pkgdesc="$pkgdesc (static library)"
+
+ cd "$pkgdir" || return 0
+--
+2.22.0
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 7e2f032fbc..f8e0de09be 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=3.4.0
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -21,6 +21,7 @@ subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
options="suid !check"
pkggroups="abuild"
source="https://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-make-default_static-depend-on-depends_static.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -68,4 +69,5 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="0ddf1cef2e79628a4de06015ba217432711ee76751ccc487fd3b1af9cae37ed1b8c5afdc0b916322472314ccee8a6d1c17ccb5b55f6eebfb54444199d2281d3e abuild-3.4.0.tar.xz"
+sha512sums="0ddf1cef2e79628a4de06015ba217432711ee76751ccc487fd3b1af9cae37ed1b8c5afdc0b916322472314ccee8a6d1c17ccb5b55f6eebfb54444199d2281d3e abuild-3.4.0.tar.xz
+bb0a550fe2742d93e49138a2909dc6ba0bf3ad598f87659cc1e10a4e78b8e8b32e8621365ba093210a1a00e6e0db45b27e756ba718c6bbcf27ce4abaa3898a08 0001-make-default_static-depend-on-depends_static.patch"