aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-10-31 15:50:16 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-10-31 15:50:48 +0200
commit5087d7db75b4ca9f3a6be66508ee05705ef3ac29 (patch)
tree2b9903791532ea3eb8e1fb0b039483b9657a1790 /main/abuild
parentcb772d75120e4ea12fbeac6db459bdaa1f951599 (diff)
downloadaports-5087d7db75b4ca9f3a6be66508ee05705ef3ac29.tar.bz2
aports-5087d7db75b4ca9f3a6be66508ee05705ef3ac29.tar.xz
main/abuild: properly detect failure of installing dependencies
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-properly-detect-failure-of-dependency-install.patch36
-rw-r--r--main/abuild/APKBUILD12
2 files changed, 44 insertions, 4 deletions
diff --git a/main/abuild/0001-abuild-properly-detect-failure-of-dependency-install.patch b/main/abuild/0001-abuild-properly-detect-failure-of-dependency-install.patch
new file mode 100644
index 0000000000..a55bc4cd57
--- /dev/null
+++ b/main/abuild/0001-abuild-properly-detect-failure-of-dependency-install.patch
@@ -0,0 +1,36 @@
+From e18d6228e7fc1e7601b4c793ef889cfd3e36fc36 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Mon, 31 Oct 2016 15:49:29 +0200
+Subject: [PATCH] abuild: properly detect failure of dependency installation
+
+---
+ abuild.in | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index 35b7995..8b6d8dd 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1889,7 +1889,8 @@ builddeps() {
+ done
+ $SUDO_APK add --upgrade --repository "$REPODEST/$repo" \
+ $apk_opt_wait \
+- --virtual .makedepends-$pkgname $builddeps
++ --virtual .makedepends-$pkgname $builddeps \
++ || return 1
+ }
+
+ # replace the md5sums in the APKBUILD
+@@ -2034,7 +2035,8 @@ deps() {
+ [ -z "$_quiet" ] && msg "Installing for build:$builddeps"
+ $SUDO_APK add $_quiet $apk_opt_wait --repository "$REPODEST/$repo" \
+ --virtual .makedepends-$pkgname \
+- $builddeps
++ $builddeps \
++ || return 1
+ if [ -n "$CBUILDROOT" ]; then
+ [ -z "$_quiet" ] && msg "Installing for host:$hostdeps"
+ $SUDO_APK add $_quiet --root "$CBUILDROOT" --repository "$REPODEST/$repo" $apk_opt_wait \
+--
+2.10.1
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 751e6dccab..06f1edce31 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=2.29.0
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -20,6 +20,7 @@ subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch"
options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-abuild-properly-detect-failure-of-dependency-install.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -62,6 +63,9 @@ gems() {
mv "$pkgdir"/usr/bin/apkbuild-gem-resolver "$subpkgdir"/usr/bin/
}
-md5sums="1a51f8786331ddf79bf46357fe938f6a abuild-2.29.0.tar.xz"
-sha256sums="06ba81d4b42e7d1ebb0761b0b0e1cbaf999acac54ab075906cecdf8f825950c1 abuild-2.29.0.tar.xz"
-sha512sums="349c0d5efaff05dc6f680a93e59a997857991520ae892426252d198aa4ef0b2854f1675ce3b1bc1bea810d5f97fae0985474ea13df3905d590b320373723990c abuild-2.29.0.tar.xz"
+md5sums="1a51f8786331ddf79bf46357fe938f6a abuild-2.29.0.tar.xz
+5dc373cd5daf473a4ee060f9cedbc9c0 0001-abuild-properly-detect-failure-of-dependency-install.patch"
+sha256sums="06ba81d4b42e7d1ebb0761b0b0e1cbaf999acac54ab075906cecdf8f825950c1 abuild-2.29.0.tar.xz
+e79ba4cdcdea3fa18d8441b8144c2db8c497523ee56927b466a701736ee9b906 0001-abuild-properly-detect-failure-of-dependency-install.patch"
+sha512sums="349c0d5efaff05dc6f680a93e59a997857991520ae892426252d198aa4ef0b2854f1675ce3b1bc1bea810d5f97fae0985474ea13df3905d590b320373723990c abuild-2.29.0.tar.xz
+1bc4bb62ee881051f41f5f68d25f8794208407f552a30bd7aad235c0bd57ebadc2a12dc21a4c1826eff3e320a5f9e7c40f89fd964144ff2f0d49f747708a61b4 0001-abuild-properly-detect-failure-of-dependency-install.patch"