aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-12-21 10:29:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-21 10:33:20 +0000
commit5162403c8a312f4a166c7fe35b0d05ac189e5cb3 (patch)
tree97ca2021e0675571893f2c93e16530a08d37368e /main/abuild
parent5f210cd0512321ffcd5b01a05e23edbd12f0a3bd (diff)
downloadaports-5162403c8a312f4a166c7fe35b0d05ac189e5cb3.tar.bz2
aports-5162403c8a312f4a166c7fe35b0d05ac189e5cb3.tar.xz
main/abuild: pass --arch whenever sysroot is used
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch62
-rw-r--r--main/abuild/APKBUILD12
2 files changed, 70 insertions, 4 deletions
diff --git a/main/abuild/0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch b/main/abuild/0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch
new file mode 100644
index 0000000000..6270d6cce6
--- /dev/null
+++ b/main/abuild/0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch
@@ -0,0 +1,62 @@
+From 971504f0ecfa59a03f30f9abe1b582c35a589590 Mon Sep 17 00:00:00 2001
+From: xentec <xentec@aix0.eu>
+Date: Wed, 21 Dec 2016 10:01:29 +0000
+Subject: [PATCH] abuild: pass --arch to apk whenever sysroot is used
+
+so we can crosscompile for different architectures
+---
+ abuild.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index f56ac03..b7e3dcc 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1048,7 +1048,7 @@ trace_apk_deps() {
+
+ case "$parch" in
+ $CBUILD_ARCH) ;;
+- $CARCH | $CTARGET_ARCH) apkroot="--root $CBUILDROOT" ;;
++ $CARCH | $CTARGET_ARCH) apkroot="--root $CBUILDROOT --arch $CTARGET_ARCH" ;;
+ esac
+
+ msg "Tracing dependencies..."
+@@ -1810,7 +1810,7 @@ builddeps() {
+ calcdeps "$BUILD_BASE"
+
+ installed_builddeps=$($APK info --installed $builddeps)
+- [ -n "$CBUILDROOT" -a -n "$hostdeps" ] && installed_hostdeps=$($APK info --root "$CBUILDROOT" --installed $hostdeps)
++ [ -n "$CBUILDROOT" -a -n "$hostdeps" ] && installed_hostdeps=$($APK info --root "$CBUILDROOT" --arch "$CTARGET_ARCH" --installed $hostdeps)
+
+ # find which deps are missing
+ for i in $builddeps; do
+@@ -1825,7 +1825,7 @@ builddeps() {
+ done
+ for i in $hostdeps; do
+ if [ "${i#\!}" != "$i" ]; then
+- if $APK info --quiet --installed --root "$CBUILDROOT" "${i#\!}"; then
++ if $APK info --quiet --installed --root "$CBUILDROOT" --arch "$CTARGET_ARCH" "${i#\!}"; then
+ error "Conflicting package installed: ${i#\!}"
+ return 1
+ fi
+@@ -2039,7 +2039,7 @@ deps() {
+ || return 1
+ if [ -n "$CBUILDROOT" ]; then
+ [ -z "$_quiet" ] && msg "Installing for host:$hostdeps"
+- $SUDO_APK add $_quiet --root "$CBUILDROOT" --repository "$REPODEST/$repo" $apk_opt_wait \
++ $SUDO_APK add $_quiet --root "$CBUILDROOT" --arch "$CTARGET_ARCH" --repository "$REPODEST/$repo" $apk_opt_wait \
+ --no-scripts --virtual .makedepends-$pkgname $hostdeps || return 1
+ fi
+ }
+@@ -2048,7 +2048,7 @@ undeps() {
+ local _quiet="$@"
+ $SUDO_APK del $_quiet $apk_opt_wait .makedepends-$pkgname
+ if [ -n "$CBUILDROOT" ]; then
+- $SUDO_APK del $_quiet --root "$CBUILDROOT" $apk_opt_wait \
++ $SUDO_APK del $_quiet --root "$CBUILDROOT" --arch "$CTARGET_ARCH" $apk_opt_wait \
+ --no-scripts .makedepends-$pkgname
+ fi
+ return 0
+--
+2.11.0
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 06f1edce31..63f1eea550 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=2.29.0
_ver=${pkgver%_git*}
-pkgrel=1
+pkgrel=2
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -21,6 +21,7 @@ options="suid"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
0001-abuild-properly-detect-failure-of-dependency-install.patch
+ 0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch
"
_builddir="$srcdir/$pkgname-$_ver"
@@ -64,8 +65,11 @@ gems() {
}
md5sums="1a51f8786331ddf79bf46357fe938f6a abuild-2.29.0.tar.xz
-5dc373cd5daf473a4ee060f9cedbc9c0 0001-abuild-properly-detect-failure-of-dependency-install.patch"
+5dc373cd5daf473a4ee060f9cedbc9c0 0001-abuild-properly-detect-failure-of-dependency-install.patch
+fd7ac6bc2c104869b6c21d75570f4e01 0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch"
sha256sums="06ba81d4b42e7d1ebb0761b0b0e1cbaf999acac54ab075906cecdf8f825950c1 abuild-2.29.0.tar.xz
-e79ba4cdcdea3fa18d8441b8144c2db8c497523ee56927b466a701736ee9b906 0001-abuild-properly-detect-failure-of-dependency-install.patch"
+e79ba4cdcdea3fa18d8441b8144c2db8c497523ee56927b466a701736ee9b906 0001-abuild-properly-detect-failure-of-dependency-install.patch
+24f0ceb383a8651f3df192773d62c7258d2ce9b3220fcedfe9a2c173d522111a 0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch"
sha512sums="349c0d5efaff05dc6f680a93e59a997857991520ae892426252d198aa4ef0b2854f1675ce3b1bc1bea810d5f97fae0985474ea13df3905d590b320373723990c abuild-2.29.0.tar.xz
-1bc4bb62ee881051f41f5f68d25f8794208407f552a30bd7aad235c0bd57ebadc2a12dc21a4c1826eff3e320a5f9e7c40f89fd964144ff2f0d49f747708a61b4 0001-abuild-properly-detect-failure-of-dependency-install.patch"
+1bc4bb62ee881051f41f5f68d25f8794208407f552a30bd7aad235c0bd57ebadc2a12dc21a4c1826eff3e320a5f9e7c40f89fd964144ff2f0d49f747708a61b4 0001-abuild-properly-detect-failure-of-dependency-install.patch
+655476f5d263701d59f85ff8c28c342d8d0710bb6c869ca7e0cb8df9f70ca2cd5af44c460b578f6ebcf320774575ce193be15830b942a956a04c0345bf27bd4e 0001-abuild-pass-arch-to-apk-whenever-sysroot-is-used.patch"