aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-07-16 19:37:52 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-07-17 15:49:55 +0300
commit51b05983cdc2978d8f0240b98846ab8d4a4c00d1 (patch)
treea50618b41d67bf984e1ebe147da681ae15c52819 /main/abuild
parent4667ad0abb52df06cd819928d61a9e5ff3a9a14f (diff)
downloadaports-51b05983cdc2978d8f0240b98846ab8d4a4c00d1.tar.bz2
aports-51b05983cdc2978d8f0240b98846ab8d4a4c00d1.tar.xz
main/abuild: upgrade to 3.0.0_rc3
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch32
-rw-r--r--main/abuild/0001-abuild-set-e-fix-for-update_config_-sub-guess.patch57
-rw-r--r--main/abuild/0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch26
-rw-r--r--main/abuild/0001-abuild-wrap-check-with-fakeroot.patch39
-rw-r--r--main/abuild/0001-add-checkroot-option.patch29
-rw-r--r--main/abuild/0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch135
-rw-r--r--main/abuild/APKBUILD27
7 files changed, 11 insertions, 334 deletions
diff --git a/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch b/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch
deleted file mode 100644
index 532b3bd0d6..0000000000
--- a/main/abuild/0001-abuild-Add-support-for-lzip-source-packages.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 5b7b1f80cbaa88849e2698d67bf2d72ac9addac4 Mon Sep 17 00:00:00 2001
-From: Breno Leitao <breno.leitao@gmail.com>
-Date: Wed, 5 Apr 2017 13:28:07 +0000
-Subject: [PATCH] abuild: Add support for lzip source packages
-
-Currently abuild does not understand .tar.lz packages, which blocks
-the inclusion of certain packages in Alpine Linux.
-
-I found this issue when adding 'ed' package to the repository. With
-this change, abuild package will now depend on lzip package. I might
-send a patch for abuild's APKBUILD.
----
- abuild.in | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/abuild.in b/abuild.in
-index c201eb2..843baab 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -418,6 +418,9 @@ default_unpack() {
- *.tar.bz2)
- msg "Unpacking $s..."
- tar -C "$srcdir" -jxf "$s" || return 1;;
-+ *.tar.lz)
-+ msg "Unpacking $s..."
-+ tar -C "$srcdir" --lzip -xf "$s" || return 1;;
- *.tar.lzma)
- msg "Unpacking $s..."
- unlzma -c "$s" | tar -C "$srcdir" -x \
---
-2.12.2
-
diff --git a/main/abuild/0001-abuild-set-e-fix-for-update_config_-sub-guess.patch b/main/abuild/0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
deleted file mode 100644
index 4fb27e3606..0000000000
--- a/main/abuild/0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From ecc1f509c6d469223cfbf4ef3f7c574de286ba6e Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 4 Apr 2017 13:12:48 +0000
-Subject: [PATCH] abuild: set -e fix for update_config_{sub,guess}
-
----
- abuild.in | 16 ++++------------
- 1 file changed, 4 insertions(+), 12 deletions(-)
-
-diff --git a/abuild.in b/abuild.in
-index f435ffc..c201eb2 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -532,8 +532,7 @@ mkusers() {
-
- # helper to update config.sub to a recent version
- update_config_sub() {
-- local changed=false
-- find . -name config.sub | while read f; do
-+ find . -name config.sub | (local changed=false; while read f; do
- if ! ./$f armv6-alpine-linux-muslgnueabihf 2>/dev/null; then
- msg "Updating $f"
- cp "$datadir"/${f##*/} "$f" || return 1
-@@ -541,16 +540,12 @@ update_config_sub() {
- else
- msg "No update needed for $f"
- fi
-- # pipe subshell will return status of last command
-- $changed
-- done
-- return $?
-+ done; $changed)
- }
-
- # helper to update config.guess to a recent version
- update_config_guess() {
-- local changed=false
-- find . -name config.guess | while read f; do
-+ find . -name config.guess | (local changed=false; while read f; do
- if grep -q aarch64 "$f" && grep -q ppc64le "$f"; then
- msg "No update needed for $f"
- else
-@@ -558,10 +553,7 @@ update_config_guess() {
- cp "$datadir"/${f##*/} "$f" || return 1
- changed=true
- fi
-- # pipe subshell will return status of last command
-- $changed
-- done
-- return $?
-+ done; $changed)
- }
-
- runpart() {
---
-2.12.2
-
diff --git a/main/abuild/0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch b/main/abuild/0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
deleted file mode 100644
index 3cc6a8b6f8..0000000000
--- a/main/abuild/0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From dec68bd03fb989c5af3c2b95d4b8fafeeed6b0f5 Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Mon, 27 Mar 2017 06:00:03 +0000
-Subject: [PATCH] abuild: use new PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH env
- variable to disable the SAT solver
-
----
- abuild.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/abuild.in b/abuild.in
-index 7cef63f..c6ee5f3 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -979,7 +979,7 @@ prepare_pkgconfig_provides() {
- continue
- fi
- local f=${i##*/}
-- local v=$(PKG_CONFIG_PATH="$dir"/usr/lib/pkgconfig pkg-config \
-+ local v=$(PKG_CONFIG_PATH="$dir"/usr/lib/pkgconfig PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH=1 pkg-config \
- --modversion ${f%.pc})
- echo "${f%.pc}=${v:-0}" >> "$controldir"/.provides-pc
- done
---
-2.12.1
-
diff --git a/main/abuild/0001-abuild-wrap-check-with-fakeroot.patch b/main/abuild/0001-abuild-wrap-check-with-fakeroot.patch
deleted file mode 100644
index 50cfec21f1..0000000000
--- a/main/abuild/0001-abuild-wrap-check-with-fakeroot.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 1ddc910eb328b4534234bd2f97e631a075241abd Mon Sep 17 00:00:00 2001
-From: William Pitcock <nenolod@dereferenced.org>
-Date: Mon, 27 Mar 2017 19:38:38 +0000
-Subject: [PATCH] abuild: wrap check() with fakeroot
-
----
- abuild.in | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/abuild.in b/abuild.in
-index c6ee5f3..f435ffc 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1401,7 +1401,7 @@ create_apks() {
- }
-
- build_abuildrepo() {
-- local d apk _build=build _check=check
-+ local d apk _build=build _check=check_fakeroot
- if ! is_function package; then
- # if package() is missing then build is called from rootpkg
- _build=true
-@@ -1626,6 +1626,13 @@ do_fakeroot() {
- fi
- }
-
-+# wrap check() with fakeroot
-+check_fakeroot() {
-+ cd "$startdir"
-+ [ -n "$FAKEROOT" ] && msg "Entering fakeroot..."
-+ do_fakeroot "$abuild_path" $color_opt $keep_build check
-+}
-+
- # build and package in fakeroot
- rootpkg() {
- local _package=package
---
-2.12.1
-
diff --git a/main/abuild/0001-add-checkroot-option.patch b/main/abuild/0001-add-checkroot-option.patch
deleted file mode 100644
index ad9503ed3b..0000000000
--- a/main/abuild/0001-add-checkroot-option.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 79525de509ccb107e388c5f4d5bb700b2d1e8831 Mon Sep 17 00:00:00 2001
-From: Shiz <hi@shiz.me>
-Date: Sat, 20 May 2017 18:32:45 +0200
-Subject: [PATCH] abuild: add !checkroot option to run tests without fakeroot
-
-Due to fakeroot being very permissive with regards to file permissions,
-some package testsuites that explicitly check for failing permission checks
-will fail.
-
-For those testsuites, give the APKBUILD the option to run the tests outside
-of a fakeroot environment.
----
- abuild.in | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/abuild.in b/abuild.in
-index c003282..0f54c87 100644
---- a/abuild.in
-+++ b/abuild.in
-@@ -1401,6 +1401,9 @@ build_abuildrepo() {
- # if package() is missing then build is called from rootpkg
- _build=true
- fi
-+ if options_has "!checkroot"; then
-+ _check=check
-+ fi
- if ! want_check; then
- _check=true
- fi
diff --git a/main/abuild/0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch b/main/abuild/0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
deleted file mode 100644
index 1935dc0a63..0000000000
--- a/main/abuild/0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-From c95263d877ca3ed953de0a114b2c1ccb9aa04b65 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Tue, 4 Apr 2017 17:55:50 +0200
-Subject: [PATCH 1/2] remove explicit `|| return 1` from all sample APKBUILDs
-
-Those statement are no longer needed because abuild now runs with
-`set -e` by default.
-
-See also: 36d5193776180385a39626a83241822736a5f6b8
----
- newapkbuild.in | 28 +++++++++++++---------------
- sample.APKBUILD | 6 +++---
- 2 files changed, 16 insertions(+), 18 deletions(-)
-
-diff --git a/newapkbuild.in b/newapkbuild.in
-index c021db5..bbe7a44 100644
---- a/newapkbuild.in
-+++ b/newapkbuild.in
-@@ -33,7 +33,7 @@ is_github_url() {
- # Build sections
- build_make() {
- cat >>APKBUILD<<__EOF__
-- make || return 1
-+ make
- __EOF__
- }
-
-@@ -45,9 +45,8 @@ build_autotools() {
- --prefix=/usr \\
- --sysconfdir=/etc \\
- --mandir=/usr/share/man \\
-- --localstatedir=/var \\
-- || return 1
-- make || return 1
-+ --localstatedir=/var
-+ make
- __EOF__
- }
-
-@@ -71,29 +70,28 @@ build_cmake() {
- -DCMAKE_BUILD_TYPE=Release \\
- -DCMAKE_CXX_FLAGS="\$CXXFLAGS" \\
- -DCMAKE_C_FLAGS="\$CFLAGS" \\
-- ${CMAKE_CROSSOPTS} \\
-- || return 1
-- make || return 1
-+ ${CMAKE_CROSSOPTS}
-+ make
- __EOF__
- }
-
- build_perl() {
- cat >>APKBUILD<<__EOF__
-- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
-- make || return 1
-+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-+ make
- __EOF__
- }
-
- build_python() {
- cat >>APKBUILD<<__EOF__
-- python setup.py build || return 1
-+ python setup.py build
- __EOF__
- }
-
- # Package sections
- package_make() {
- cat >>APKBUILD<<__EOF__
-- make DESTDIR="\$pkgdir" install || return 1
-+ make DESTDIR="\$pkgdir" install
- __EOF__
- }
-
-@@ -103,14 +101,14 @@ package_autotools() {
-
- package_perl() {
- cat >>APKBUILD<<__EOF__
-- make DESTDIR="\$pkgdir" install || return 1
-+ make DESTDIR="\$pkgdir" install
- find "\$pkgdir" \\( -name perllocal.pod -o -name .packlist \\) -delete
- __EOF__
- }
-
- package_python() {
- cat >>APKBUILD<<__EOF__
-- python setup.py install --prefix=/usr --root="\$pkgdir" || return 1
-+ python setup.py install --prefix=/usr --root="\$pkgdir"
- __EOF__
- }
-
-@@ -273,9 +271,9 @@ __EOF__
- cat >>APKBUILD<<__EOF__
-
- install -m755 -D "\$srcdir"/\$pkgname.initd \\
-- "\$pkgdir"/etc/init.d/\$pkgname || return 1
-+ "\$pkgdir"/etc/init.d/\$pkgname
- install -m644 -D "\$srcdir"/\$pkgname.confd \\
-- "\$pkgdir"/etc/conf.d/\$pkgname || return 1
-+ "\$pkgdir"/etc/conf.d/\$pkgname
- __EOF__
- fi
- cat >>APKBUILD<<__EOF__
-diff --git a/sample.APKBUILD b/sample.APKBUILD
-index 30184c5..95a6634 100644
---- a/sample.APKBUILD
-+++ b/sample.APKBUILD
-@@ -31,12 +31,12 @@ build() {
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
-- make || return 1
-+ make
- }
-
- package() {
- cd "$builddir"
-- make DESTDIR="$pkgdir" install || return 1
-+ make DESTDIR="$pkgdir" install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-@@ -47,7 +47,7 @@ check() {
- # uncomment the 2 lines below if there is a testsuite. we assume the testsuite
- # is run using "make check", which is the default for autotools-based build systems.
- # cd "$builddir"
-- # make check || return 1
-+ # make check
- }
-
- md5sums="" #generate with 'abuild checksum'
---
-2.12.2
-
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index b5ce3289a3..e16104bbad 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abuild
-pkgver=3.0.0_rc2
+pkgver=3.0.0_rc3
_ver=${pkgver%_git*}
-pkgrel=8
+pkgrel=0
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -16,16 +16,11 @@ makedepends_build="pkgconfig"
makedepends_host="libressl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch"
+subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
+ abuild-rootbld:_rootbld:noarch"
options="suid !check"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
- 0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
- 0001-abuild-wrap-check-with-fakeroot.patch
- 0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
- 0001-abuild-Add-support-for-lzip-source-packages.patch
- 0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
- 0001-add-checkroot-option.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -66,10 +61,10 @@ gems() {
mv "$pkgdir"/usr/bin/apkbuild-gem-resolver "$subpkgdir"/usr/bin/
}
-sha512sums="bb6fa7af3144db99839c24db63e17179d73f659a76c86d530923158b37fad3fcd73ea992f9d5f4ac3c48c13ccebb62ffbe461b3871dcb4b7b1ca6efd934e4be2 abuild-3.0.0_rc2.tar.xz
-65e0605a23a5f8df6024533b054ce6e098bfc1431220d8487e9d5f521aede7c0c8fc47f5f119d868da48d8f69e6fbc3fe101f71e3415a66797829623bb5a7a48 0001-abuild-use-new-PKG_CONFIG_MAXIMUM_TRAVERSE_DEPTH-env.patch
-0e5b64ad175efc4a06197a5e131878e5532539c78ffd8d5aa28a99c9684aa6eec8bc95fdca1c99b916a58c61ddf8d0b7602b1bc9aee276f7a40d82f970c0ad7c 0001-abuild-wrap-check-with-fakeroot.patch
-dda641f0ce2bddc8f3d7cf4a3538afe699bda56a5172bd56104de7252796da20025ed36f9401220d8e2fd072297efad94da4be4ed8831e9f9d14ad75c9c8859d 0001-abuild-set-e-fix-for-update_config_-sub-guess.patch
-084171ed1e276c02f58dfade28c013d0160fb8a7b87ee03684ffb16c2bb1c64f8b9d98adc947c7b0211ba7fb2d8ef2c590abd9fed80676db52b7829da495d291 0001-abuild-Add-support-for-lzip-source-packages.patch
-51d506f657388215979b551f79a98c46f17c6deba719ec9f0fd7ffc0fd3583fc2870123e309f08c4b7a8958e1742168ec91a57901efc6a72277bb6039807132c 0001-remove-explicit-return-1-from-all-sample-APKBUILDs.patch
-6909448e91cd8ba78d0646f550f57562291ef34bcdcef0690166fc7ef145810109836c56cfb086f54ebe6f7dd57ca6968ab532a50217a758a50edf0f9683bf03 0001-add-checkroot-option.patch"
+_rootbld() {
+ pkgdesc="Build packages in chroot"
+ depends="abuild bubblewrap gettext git"
+ mkdir -p "$subpkgdir"
+}
+
+sha512sums="4aef6556425f9289e4597edb0b581d85feea38fe38507fd70c9229350a49a77b595ea4f9dbacef6d0ba58955c447a3ba06d2f6b17096d40ae4b7abf39351e486 abuild-3.0.0_rc3.tar.xz"