aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-07 21:17:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-07 21:17:11 +0000
commit6b5e7c54797f8ff2dc2852de34027c968da4eadb (patch)
tree61c701426d3e39c37e254891e9aa7f43b379dc86 /main/abuild
parent4cf9ba9e467086af0d06bf30908f97932058b140 (diff)
downloadaports-6b5e7c54797f8ff2dc2852de34027c968da4eadb.tar.bz2
aports-6b5e7c54797f8ff2dc2852de34027c968da4eadb.tar.xz
main/abuild: revert reproducible build changes
they caused 'BAD archive' errors for apk.
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-Revert-abuild-make-built-package-reproducible.patch48
-rw-r--r--main/abuild/APKBUILD6
2 files changed, 52 insertions, 2 deletions
diff --git a/main/abuild/0001-Revert-abuild-make-built-package-reproducible.patch b/main/abuild/0001-Revert-abuild-make-built-package-reproducible.patch
new file mode 100644
index 0000000000..dd262541b9
--- /dev/null
+++ b/main/abuild/0001-Revert-abuild-make-built-package-reproducible.patch
@@ -0,0 +1,48 @@
+From 51d9e3bcb9fe99a67059e08d7b6fb6ca6a2b75c2 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 7 Nov 2019 20:41:27 +0000
+Subject: [PATCH] Revert "abuild: make built package reproducible"
+
+The introduction of the --pax-options seems to confuse apk and resulted
+in `BAD archive' errors.
+
+This reverts commit f04a2ee34b28a38c4349ef1f94686a07afce730f.
+---
+ abuild.in | 14 +++-----------
+ 1 file changed, 3 insertions(+), 11 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index ad9f92b..91f9e1d 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -1565,11 +1565,7 @@ create_apks() {
+ # normalize timestamps
+ find . -exec touch -h -d "@$SOURCE_DATE_EPOCH" {} +
+
+- tar --xattrs \
+- --format=posix \
+- --pax-option=exthdr.name=%d/PaxHeaders/%f,delete=atime,delete=ctime,delete=mtime \
+- --mtime="@${SOURCE_DATE_EPOCH}" \
+- -f - -c "$@" | abuild-tar --hash | $gzip -n -9 >"$dir"/data.tar.gz
++ tar --xattrs -f - -c "$@" | abuild-tar --hash | $gzip -9 >"$dir"/data.tar.gz
+
+ msg "Create checksum..."
+ # append the hash for data.tar.gz
+@@ -1579,12 +1575,8 @@ create_apks() {
+
+ # control.tar.gz
+ cd "$dir"
+- tar \
+- --format=posix \
+- --pax-option=exthdr.name=%d/PaxHeaders/%f,delete=atime,delete=ctime,delete=mtime \
+- --mtime="@${SOURCE_DATE_EPOCH}" \
+- -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
+- | $gzip -n -9 > control.tar.gz
++ tar -f - -c $(cat "$dir"/.metafiles) | abuild-tar --cut \
++ | $gzip -9 > control.tar.gz
+ abuild-sign -q control.tar.gz || exit 1
+
+ msg "Create $apk"
+--
+2.23.0
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 75f73ef5f0..b8c000403e 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=3.5.0_rc1
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -21,6 +21,7 @@ subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
options="suid !check"
pkggroups="abuild"
source="https://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-Revert-abuild-make-built-package-reproducible.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -68,4 +69,5 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="489198056857246adc7f61ca65e32d62717e872e11e284b83045f66a7b9b026cc6eb8d29215d94cee50a755f3320c1e8c51eca9a9763bd81da985b2f0713e4ee abuild-3.5.0_rc1.tar.xz"
+sha512sums="489198056857246adc7f61ca65e32d62717e872e11e284b83045f66a7b9b026cc6eb8d29215d94cee50a755f3320c1e8c51eca9a9763bd81da985b2f0713e4ee abuild-3.5.0_rc1.tar.xz
+5778fa633dd55f7b40f4368f75c214aaa234c9240a14255b7d69ee86253b7d480d2458eb8c6d6bf5b6824cb7f785e6d64416efc9639485e65203c17abdbccc8c 0001-Revert-abuild-make-built-package-reproducible.patch"