aboutsummaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-09-26 09:58:58 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-26 09:59:55 +0000
commitd8635e8cc8228d2acc6e5bb5b640b3b4671442a4 (patch)
tree6ff21486de5d45a0399d43492c935e273b449b50 /main/abuild
parent5cf46f1e998bcd93fa3a982af1000712afbffddd (diff)
downloadaports-d8635e8cc8228d2acc6e5bb5b640b3b4671442a4.tar.bz2
aports-d8635e8cc8228d2acc6e5bb5b640b3b4671442a4.tar.xz
main/abuild: use full version, do not strip standalone elf images
ref: https://github.com/alpinelinux/aports/pull/1714
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/0001-abuild-do-not-try-to-strip-standalone-elf-images.patch36
-rw-r--r--main/abuild/APKBUILD10
2 files changed, 42 insertions, 4 deletions
diff --git a/main/abuild/0001-abuild-do-not-try-to-strip-standalone-elf-images.patch b/main/abuild/0001-abuild-do-not-try-to-strip-standalone-elf-images.patch
new file mode 100644
index 0000000000..ee4fc8d463
--- /dev/null
+++ b/main/abuild/0001-abuild-do-not-try-to-strip-standalone-elf-images.patch
@@ -0,0 +1,36 @@
+From 4736a56c8e6ffee2f9101ab8d2b814eb239f5889 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Tue, 26 Sep 2017 07:26:02 +0000
+Subject: [PATCH 1/1] abuild: do not try to strip standalone elf images
+
+Guile uses ELF is internal object format, and creates them as
+"no machine" and "standlone" OSABI. Scanelf supports printing
+OSABI, so use that to filter these out.
+See: https://github.com/alpinelinux/aports/pull/1714
+
+This also removes unneccessary 'sed' from the pipeline as it's
+simple to read each field outputted by scanelf.
+---
+ abuild.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/abuild.in b/abuild.in
+index dae99b3..ef80891 100644
+--- a/abuild.in
++++ b/abuild.in
+@@ -2142,9 +2142,9 @@ stripbin() {
+ esac
+
+ msg "Stripping binaries"
+- scanelf --recursive --nobanner --etype "ET_DYN,ET_EXEC" . \
+- | sed -e 's:^ET_DYN ::' -e 's:^ET_EXEC ::' \
+- | while read filename; do
++ scanelf --recursive --nobanner --osabi --etype "ET_DYN,ET_EXEC" . \
++ | while read type osabi filename; do
++ [ "$osabi" != "STANDALONE" ] || continue
+ local XATTR=$(getfattr --match="" --dump "${filename}")
+ "${stripcmd}" "${filename}"
+ if [ -n "$XATTR" ]; then
+--
+2.14.1
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index d64fe8e176..20960c161b 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,7 +2,7 @@
pkgname=abuild
pkgver=3.0.1
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="http://git.alpinelinux.org/cgit/abuild/"
arch="all"
@@ -21,6 +21,7 @@ subpackages="apkbuild-cpan:cpan:noarch apkbuild-gem-resolver:gems:noarch
options="suid !check"
pkggroups="abuild"
source="http://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz
+ 0001-abuild-do-not-try-to-strip-standalone-elf-images.patch
"
builddir="$srcdir/$pkgname-$_ver"
@@ -33,13 +34,13 @@ prepare() {
build() {
cd "$builddir"
- make
+ make VERSION="$pkgver-r$pkgrel"
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir"
+ make install VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
install -d -m 775 -g abuild "$pkgdir"/var/cache/distfiles
@@ -67,4 +68,5 @@ _rootbld() {
mkdir -p "$subpkgdir"
}
-sha512sums="390f25ba57bf827eb55cf789ec6e4489909d9c0b0ae7311944c569c3de23744d8985f9ba333234f45e294568a4de0cc1673bbd6f801950763ab1313333b848e1 abuild-3.0.1.tar.xz"
+sha512sums="390f25ba57bf827eb55cf789ec6e4489909d9c0b0ae7311944c569c3de23744d8985f9ba333234f45e294568a4de0cc1673bbd6f801950763ab1313333b848e1 abuild-3.0.1.tar.xz
+e88777152a469ebb36efbfd79fd0293980aebb7260b56ee14d6ca131c7173dc578b4095514cca8fc6202b80b55f12935d7dcd578d602715a8ed61aa46db852f5 0001-abuild-do-not-try-to-strip-standalone-elf-images.patch"