aboutsummaryrefslogtreecommitdiffstats
path: root/main/acf-lib
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2015-01-12 16:55:50 +0000
committerTed Trask <ttrask01@yahoo.com>2015-01-12 16:55:50 +0000
commitb7de30427b75ea93978da85a70de59952d8363d7 (patch)
tree81c82eba8597cee0da1b3257be68dd81b5d02855 /main/acf-lib
parent1910a57d42fdaded5a8c39f969466c1d285ee238 (diff)
downloadaports-b7de30427b75ea93978da85a70de59952d8363d7.tar.bz2
aports-b7de30427b75ea93978da85a70de59952d8363d7.tar.xz
main/acf-lib: Temporary patch to install for both Lua 5.1 and 5.2
Diffstat (limited to 'main/acf-lib')
-rw-r--r--main/acf-lib/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/acf-lib/APKBUILD b/main/acf-lib/APKBUILD
index 82801a3c57..88cee03cc1 100644
--- a/main/acf-lib/APKBUILD
+++ b/main/acf-lib/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
+_luaversions="5.1 5.2"
pkgname=acf-lib
pkgver=0.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="Lua libraries for ACF"
url="http://git.alpinelinux.org/cgit/acf-lib"
arch="noarch"
@@ -12,7 +13,10 @@ source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
package() {
cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ for _i in $_luaversions; do
+ sed "s~luadir=.*~luadir=\${prefix}/share/lua/$_i/acf~" -i config.mk
+ make DESTDIR="$pkgdir" install
+ done
}
md5sums="25fb1ecf484a76557cac5eb7839e0bc5 acf-lib-0.7.2.tar.xz"
sha256sums="e62b5f103d06035016695b06fbcb95671abe07c3b998e44e9b0618321ecf1d16 acf-lib-0.7.2.tar.xz"