aboutsummaryrefslogtreecommitdiffstats
path: root/main/aiccu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-16 08:02:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-16 08:02:10 +0000
commitb437ffce4103fb116a27506fe3d21e91031b59bf (patch)
treee2c5ff6ad7098aa3d6072ed17a66fba7413f809d /main/aiccu
parentdc93e81cd095b0506ebead1de16797a96fcbdb00 (diff)
downloadaports-b437ffce4103fb116a27506fe3d21e91031b59bf.tar.bz2
aports-b437ffce4103fb116a27506fe3d21e91031b59bf.tar.xz
main/aiccu: moved from testing
Diffstat (limited to 'main/aiccu')
-rw-r--r--main/aiccu/APKBUILD54
-rw-r--r--main/aiccu/aiccu.initd40
-rw-r--r--main/aiccu/fix_linking.patch29
-rw-r--r--main/aiccu/musl_does_not_have_res_ninit.patch29
4 files changed, 152 insertions, 0 deletions
diff --git a/main/aiccu/APKBUILD b/main/aiccu/APKBUILD
new file mode 100644
index 0000000000..809456a84a
--- /dev/null
+++ b/main/aiccu/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=aiccu
+pkgver=20070115
+pkgrel=1
+pkgdesc="Automatic IPv6 Connectivity Client Utility"
+url="https://www.sixxs.net/"
+arch="all"
+license="SixXS"
+depends="iproute2"
+makedepends="gnutls-dev"
+source="https://www.sixxs.net/archive/sixxs/aiccu/unix/${pkgname}_${pkgver}.tar.gz
+ musl_does_not_have_res_ninit.patch
+ fix_linking.patch
+ aiccu.initd
+ "
+subpackages="${pkgname}-doc"
+
+_builddir="$srcdir"/${pkgname}
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in ${srcdir}/*.patch; do
+ patch -p1 -i ${pf} || return 1
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ make -C unix-console HAVE_SYSTEMD=0 || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ install -D -m0755 "${_builddir}"/unix-console/aiccu ${pkgdir}/usr/sbin/aiccu || return 1
+ install -D -m0755 "${srcdir}"/aiccu.initd ${pkgdir}/etc/init.d/aiccu || return 1
+ install -D -m0644 "${_builddir}"/doc/aiccu.conf ${pkgdir}/etc/aiccu.conf || return 1
+ install -D -m0644 "${_builddir}"/doc/HOWTO ${pkgdir}/usr/share/doc/aiccu/HOWTO || return 1
+ install -D -m0644 "${_builddir}"/doc/README ${pkgdir}/usr/share/doc/aiccu/README || return 1
+ install -D -m0644 "${_builddir}"/doc/changelog ${pkgdir}/usr/share/doc/aiccu/changelog || return 1
+}
+md5sums="c9bcc83644ed788e22a7c3f3d4021350 aiccu_20070115.tar.gz
+54a0045d766a1f0696c46800a39a8d92 musl_does_not_have_res_ninit.patch
+cb9060144aa68e3e2be394427a10f39f fix_linking.patch
+d34e071a9c8312f5cda899199e9e7095 aiccu.initd"
+sha256sums="2260f426c13471169ccff8cb4a3908dc5f79fda18ddb6a55363e7824e6c4c760 aiccu_20070115.tar.gz
+f748e1df9ec8381709d983f60282c9dde839bd00eb3db551e45578e155e6772c musl_does_not_have_res_ninit.patch
+df7820a873e720badefe6bc71b658ce8e0c1c5ac2c16f04e5174f3a7d27b5053 fix_linking.patch
+d8c57b5475ed191781f6ce564124320f4b9dabc47f25dbcd5b047afa271006d6 aiccu.initd"
+sha512sums="15b2f0dab51843e58abbd8a0cc13139e492057ee348e368e1b65476bb2760119e88982cd03ffc6ec2cb563a1b7a061e1f66a98861eaad15972d486ac17b7bc78 aiccu_20070115.tar.gz
+a13a112eb8bffe125cff9452f9643d516ba4d7168c23e2e15280da9c21e7fa373b8f40cbbf52d353a556820db6b528309055b3a67efc4366e914e4d8e0717aec musl_does_not_have_res_ninit.patch
+c131ec6d79caa38d315ac938718d0752c62dee148fe7200eb7ea908d2911ff2e99814505552207b676f0a6e25e36d3ecaa9e4ada59310e150cc3faa603662821 fix_linking.patch
+42bffa006170ee27f288446cb773d5d9bac6adeb1914e53a6ec563c21eafb98528f77bce1e5d2a17db50f628df6b526869b3e9d3446fa68cee321bd9bf939e9b aiccu.initd"
diff --git a/main/aiccu/aiccu.initd b/main/aiccu/aiccu.initd
new file mode 100644
index 0000000000..1c8dec0105
--- /dev/null
+++ b/main/aiccu/aiccu.initd
@@ -0,0 +1,40 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after ntpd
+}
+
+checkconfig() {
+ # Verify that the configuration file exists
+ if [ ! -f /etc/aiccu.conf ]; then
+ eerror "AICCU Configuration file /etc/aiccu.conf doesn't exist"
+ return 1
+ fi
+
+ # Verify that the configuration is correct
+ if [ `grep -c "^username" /etc/aiccu.conf 2>/dev/null` -ne 1 ]; then
+ eerror "AICCU is not configured, edit /etc/aiccu.conf first"
+ return 1
+ fi
+}
+
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting aiccu"
+ start-stop-daemon --start --quiet --exec /usr/sbin/aiccu -- start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping aiccu"
+ start-stop-daemon --stop --pidfile /var/run/aiccu.pid --quiet --exec /usr/sbin/aiccu -- stop
+ eend $?
+}
+
+restart() {
+ stop
+ sleep 3
+ start
+}
diff --git a/main/aiccu/fix_linking.patch b/main/aiccu/fix_linking.patch
new file mode 100644
index 0000000000..100220149b
--- /dev/null
+++ b/main/aiccu/fix_linking.patch
@@ -0,0 +1,29 @@
+--- a/unix-console/Makefile
++++ b/unix-console/Makefile
+@@ -42,7 +42,7 @@
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LIBS += -lgnutls
+ endif
+
+ # Linux
+@@ -50,7 +50,7 @@
+ CFLAGS += -D_LINUX -D HAS_IFHEAD -D AICCU_TYPE="\"linux\""
+ SRCS += ../common/aiccu_linux.c
+ OBJS += ../common/aiccu_linux.o
+-LDFLAGS += -lpthread -lresolv
++LIBS += -lpthread -lresolv
+ endif
+
+ # FreeBSD
+@@ -144,7 +144,7 @@
+ all: aiccu
+
+ aiccu: $(OBJS) ${SRCS} ${INCS}
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+ ifeq ($(shell echo $(CFLAGS) | grep -c "DEBUG"),0)
+ ifeq ($(shell echo "$(RPM_OPT_FLAGS)" | wc -c),1)
+ strip $@
diff --git a/main/aiccu/musl_does_not_have_res_ninit.patch b/main/aiccu/musl_does_not_have_res_ninit.patch
new file mode 100644
index 0000000000..1934afbc50
--- /dev/null
+++ b/main/aiccu/musl_does_not_have_res_ninit.patch
@@ -0,0 +1,29 @@
+--- aiccu/common/resolver.c
++++ aiccu.new/common/resolver.c
+@@ -26,7 +26,7 @@
+
+ int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
+ {
+-#ifdef _LINUX
++#ifdef __GLIBC__
+ struct __res_state res;
+ #endif
+ unsigned char answer[8192];
+@@ -38,7 +38,7 @@
+ uint16_t type = 0, class = 0;
+ uint32_t ttl = 0;
+
+-#ifdef _LINUX
++#ifdef __GLIBC__
+ memset(&res, 0, sizeof(res));
+ res.options = RES_DEBUG;
+ res_ninit(&res);
+@@ -47,7 +47,7 @@
+ #endif
+
+ memset(answer, 0, sizeof(answer));
+-#ifdef _LINUX
++#ifdef __GLIBC__
+ ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
+ #else
+ ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));