aboutsummaryrefslogtreecommitdiffstats
path: root/main/alpine-conf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-01-19 01:50:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-19 02:04:52 +0000
commit5e4b9a0dabf044e056c6193c4552e4e35a11ef47 (patch)
tree4e9ff9c1bab2ef62463fee17f2a5bac22b6f4890 /main/alpine-conf
parentf92a41f7329b5e337476e1cf978b198a2592ffc9 (diff)
downloadaports-5e4b9a0dabf044e056c6193c4552e4e35a11ef47.tar.bz2
aports-5e4b9a0dabf044e056c6193c4552e4e35a11ef47.tar.xz
main/alpine-conf: fix update-kernel to handle -vanilla suffix
Diffstat (limited to 'main/alpine-conf')
-rw-r--r--main/alpine-conf/0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch36
-rw-r--r--main/alpine-conf/APKBUILD10
2 files changed, 42 insertions, 4 deletions
diff --git a/main/alpine-conf/0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch b/main/alpine-conf/0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch
new file mode 100644
index 0000000000..e52a1116ee
--- /dev/null
+++ b/main/alpine-conf/0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch
@@ -0,0 +1,36 @@
+From ac90985a323a376b8567710105fdb01e6102e6be Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 19 Jan 2018 01:33:11 +0000
+Subject: [PATCH] update-kernel: handle -vanilla suffix in System.map, config
+ and vmlinuz
+
+Previously the vanilla kernel did not add any suffix to System.map,
+config and vmlinuz for the vanilla kernel, but it does now. Fix
+update-kernel to handle both cases.
+
+Note also that /lib/modules/$ver still does not have any -vanilla
+suffix.
+---
+ update-kernel.in | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/update-kernel.in b/update-kernel.in
+index 88f266b..930b3eb 100644
+--- a/update-kernel.in
++++ b/update-kernel.in
+@@ -254,7 +254,11 @@ mkinitfs $MKINITFS_ARGS -q -b $ROOT -F "$features base squashfs" \
+ -o "$STAGING/initramfs-$FLAVOR" "$KVER"
+
+ for file in System.map config vmlinuz; do
+- cp "$BOOT/$file$KVER_FLAVOR" $STAGING
++ if [ -f "$BOOT/$file-$FLAVOR" ]; then
++ cp "$BOOT/$file-$FLAVOR" $STAGING
++ else
++ cp "$BOOT/$file" $STAGING
++ fi
+ done
+
+ if [ "$MNTDIR" ]; then
+--
+2.15.0
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 69da636624..613e3c5f8c 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,27 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
license="MIT"
depends="openrc>0.13 busybox>=1.26.1-r3"
source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
+ 0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch
"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- make VERSION=$pkgver-r$pkgrel || return 1
+ make VERSION=$pkgver-r$pkgrel
}
package() {
cd "$builddir"
- make install PREFIX= DESTDIR="$pkgdir" || return 1
+ make install PREFIX= DESTDIR="$pkgdir"
for i in commit exclude include status update; do
ln -s lbu "$pkgdir"/sbin/lbu_$i
done
}
-sha512sums="13fed0532aa84c39d54d2c905f31276c4b8f2d596c33bebd796f36e2e796f2d66c172440c20d19e8753f531204cacecc79ca24cd3ec1b24e3e51de251297207b alpine-conf-3.7.0.tar.xz"
+sha512sums="13fed0532aa84c39d54d2c905f31276c4b8f2d596c33bebd796f36e2e796f2d66c172440c20d19e8753f531204cacecc79ca24cd3ec1b24e3e51de251297207b alpine-conf-3.7.0.tar.xz
+fdeb9f0c67a81b545e372199558fc81222f0c6599d42f0731f7fe0398bc0b9deb631c8e98f7147fb63b570ac0e97497d416332ddbfefbb833073df9c1baffee0 0001-update-kernel-handle-vanilla-suffix-in-System.map-co.patch"